[LAU] wine on 64bit debian

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
From: Atte <atte@...>
To: linux-audio-user <Linux-audio-user@...>
Date: Saturday, March 29, 2014 - 9:46 am

Hi

I'm trying to install wine on my fresh 64bit debian.

$ sudo apt-get install wine
$ wine

This gives me a window with the following:

------------------
This is the wine64-bin helper package, which does not provide wine itself,
but instead exists solely to provide the following information about
enabling multiarch on your system in order to be able to install and run
the 32-bit wine packages.

The following commands should be issued as root or via sudo in order to
enable multiarch (the last command installs 32-bit wine):

# dpkg --add-architecture i386
# apt-get update
# apt-get install wine-bin:i386

Be very careful as spaces matter above. Note that this package
(wine64-bin) will be removed in the process. For more information on
the multiarch conversion, see: http://wiki.debian.org/Multiarch/HOWTO
---------------------------

Hmm, this sounds a little fishy, I went ahead and ran the proposed:

$ sudo apt-get install wine-bin:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wine-bin:i386 : Depends: libc6:i386 (>= 2.4) but it is not going to be
installed
Depends: libwine-bin:i386 (= 1.4.1-4) but it is not
going to be installed
E: Unable to correct problems, you have held broken packages.

As a final step I tried:

$ sudo apt-get install wine-bin:i386 libc6:i386 libwine-bin:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ant : Depends: default-jre-headless or
java2-runtime-headless or
java5-runtime-headless or
java6-runtime-headless
libc6 : Depends: libgcc1 but it is not going to be installed
Breaks: libc6:i386 (!= 2.18-4) but 2.13-38+deb7u1 is to be
installed
libc6:i386 : Breaks: libc6 (!= 2.13-38+deb7u1) but 2.18-4 is to be
installed
libcairo2 : Depends: libfontconfig1 (>= 2.9.0) but it is not going to
be installed
Depends: libfreetype6 (>= 2.3.5) but it is not going to be
installed
Depends: libpixman-1-0 (>= 0.21.6) but it is not going to
be installed
Depends: libpng12-0 (>= 1.2.13-4) but it is not going to
be installed
Depends: libxcb-render0 but it is not going to be installed
Depends: libxcb-shm0 but it is not going to be installed
Depends: libxcb1 (>= 1.6) but it is not going to be installed
Depends: libxrender1 but it is not going to be installed
libcurl3-gnutls : Depends: libgcrypt11 (>= 1.4.5) but it is not going
to be installed
Depends: libgnutls26 (>= 2.12.17-0) but it is not
going to be installed
Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but it is
not going to be installed
Depends: libidn11 (>= 1.13) but it is not going to
be installed
Depends: libldap-2.4-2 (>= 2.4.7) but it is not
going to be installed
Depends: librtmp0 (>= 2.3) but it is not going to be
installed
Depends: libssh2-1 (>= 1.2.6) but it is not going to
be installed
Recommends: ca-certificates but it is not going to
be installed
libdbus-glib-1-2 : Depends: libdbus-1-3 (>= 1.2.16) but it is not
going to be installed
libglib2.0-0 : Depends: libffi5 (>= 3.0.4) but it is not going to be
installed
Depends: libpcre3 (>= 8.10) but it is not going to be
installed
Depends: libselinux1 (>= 1.32) but it is not going to
be installed
Recommends: shared-mime-info
libimlib2 : Depends: libbz2-1.0 but it is not going to be installed
Depends: libfreetype6 (>= 2.2.1) but it is not going to be
installed
Depends: libgif4 (>= 4.1.4) but it is not going to be
installed
Depends: libid3tag0 (>= 0.15.1b) but it is not going to be
installed
Depends: libjpeg8 (>= 8c) but it is not going to be installed
Depends: libpng12-0 (>= 1.2.13-4) but it is not going to
be installed
Depends: libtiff4 (> 3.9.5-3~) but it is not going to be
installed
liblua5.1-0 : Depends: libgcc1 (>= 1:4.1.1) but it is not going to be
installed
Depends: libstdc++6 (>= 4.1.1) but it is not going to be
installed
libwine-bin:i386 : Depends: libwine:i386 (= 1.4.1-4) but it is not
going to be installed
libx11-6 : Depends: libxcb1 (>= 1.2) but it is not going to be installed
libxft2 : Depends: libfontconfig1 (>= 2.9.0) but it is not going to be
installed
Depends: libfreetype6 (>= 2.3.5) but it is not going to be
installed
Depends: libxrender1 but it is not going to be installed
libxml2 : Depends: liblzma5 (>= 5.1.1alpha+20120614) but it is not
going to be installed
Recommends: xml-core but it is not going to be installed
wine-bin:i386 : Depends: debconf:i386 (>= 0.5) or
debconf-2.0:i386
Depends: x11-utils:i386 or
xbase-clients:i386 (>= 4.0) but it is not
installable or
xcontrib:i386 but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.

So it seems that I'm not really on the right track here, any ideas?

Thanks in advance!
--
Atte

http://atte.dk http://modlys.dk
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] wine on 64bit debian, Atte, (Sat Mar 29, 9:46 am)
Re: [LAU] wine on 64bit debian, Simon Wise, (Sat Mar 29, 2:51 pm)
Re: [LAU] wine on 64bit debian, Will Godfrey, (Sat Mar 29, 10:08 am)
Re: [LAU] wine on 64bit debian, Ralf Mardorf, (Sat Mar 29, 10:06 am)