Re: [LAU] Testing JACK and PA latency

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Friday, September 20, 2013 - 8:59 am

For comparison taking PA out of the graph:

jack_iodelay (out) -> ecasound (in) -> ecasound (out) -> system (out) ->
system (in) -> jack_iodelay (in)

I see stable performance with the following result after a few seconds of
"burn in".

218.905 frames 4.561 ms total roundtrip latency
extra loopback latency: 26 frames
use 13 for the backend arguments -I and -O ?? Inv

However after switching to the browser and writing this email then
switching back again I see the following data:

33114.906 frames 689.894 ms total roundtrip latency
extra loopback latency: 32922 frames
use 16461 for the backend arguments -I and -O ??

Switching back to the browser to write some more I see the a stable
4.561ms again and that has stayed stable after a couple of switches
between browser/console. After more test the latency is definitely being
affected by xorg and switching between apps but not every time.

With only jack_iodelay running I see the cpu load hovering between 30 to
40%. With ecasound added to the graph I see cpu load hovering between 30
to 50%.

Ecasound has not reported any underruns during this test. With PA included
I had 32 underruns over night (approx 6 hours of running).

The things I am now trying to rule out or trace:

- Potential priority conflicts between jack and xorg (I'm running gnome3)
- What causes erratic results with PA in the graph

Suggestions welcome.

--
Patrick Shirkey
Boost Hardware Ltd
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Testing JACK and PA latency, Patrick Shirkey, (Thu Sep 19, 8:46 am)
Re: [LAU] Testing JACK and PA latency, Fons Adriaensen, (Thu Sep 19, 9:42 am)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Thu Sep 19, 10:04 am)
Re: [LAU] Testing JACK and PA latency, Fons Adriaensen, (Thu Sep 19, 10:46 am)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Wed Sep 25, 1:32 pm)
Re: [LAU] Testing JACK and PA latency, Len Ovens, (Thu Sep 19, 2:01 pm)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Thu Sep 19, 2:21 pm)
Re: [LAU] Testing JACK and PA latency, Len Ovens, (Thu Sep 19, 11:48 pm)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Fri Sep 20, 12:57 am)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Fri Sep 20, 8:59 am)
Re: [LAU] Testing JACK and PA latency, Fons Adriaensen, (Fri Sep 20, 10:31 am)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Fri Sep 20, 10:41 am)
Re: [LAU] Testing JACK and PA latency, Fons Adriaensen, (Fri Sep 20, 3:13 pm)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Fri Sep 20, 6:07 pm)
Re: [LAU] Testing JACK and PA latency, Fons Adriaensen, (Fri Sep 20, 7:08 pm)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Sat Sep 21, 11:27 am)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Thu Sep 19, 3:40 pm)
Re: [LAU] Testing JACK and PA latency, Fons Adriaensen, (Thu Sep 19, 12:31 pm)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Thu Sep 19, 12:35 pm)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Thu Sep 19, 10:26 am)
Re: [LAU] Testing JACK and PA latency, Hartmut Noack, (Thu Sep 19, 9:20 am)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Thu Sep 19, 9:39 am)
Re: [LAU] Testing JACK and PA latency, Len Ovens, (Thu Sep 19, 1:49 pm)
Re: [LAU] Testing JACK and PA latency, Patrick Shirkey, (Thu Sep 19, 2:04 pm)