[LAU] Xth sense on archlinux

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: linux-audio-user <linux-audio-user@...>
Cc: <fero.kiraly@...>
Date: Tuesday, May 7, 2013 - 11:56 am

--047d7b6dce12f3c55c04dc1f8217
Content-Type: text/plain; charset=ISO-8859-1

Hi Fero,

the errors you reported happens only with the new pd-extended 43.4; that
is, with pdx 42.5 everything works fine.

In the latest pdx release, the object [line3] and the library in which it
was included have been removed. These were not maintained by me. So I
compiled binaries for Linux ubuntu and mac and included them in the
xth-sense-lib.

You can find line3 source here:
http://pure-data.svn.sourceforge.net/viewvc/pure-data/branches/pd-extend...

simply compile it and add it to the xth-sense-lib.

As for the second error, that is a general Pdx bug, apparently related to
GOP (graph on parent) objects. I managed to isolate it and submit a report,
but it has to be solved yet.

When did you downloaded the Xth Sense software? Very recently I updated the
XS software to a new version which seemed to have worked well against this
bug:
http://res.marcodonnarumma.com/projects/xth-sense/#download

it would be great if you could test it out, if you have an older version.

on a side note, I'm in the process of updating the documentation and the
software to version 2.0, but I've been slowed down by the above issues
appeared with pdx 43.4. So, hopefully soon this issues should be addressed
adequately and documented.

hope this helps!
best,
M

\\\\\\\\\\\\\\\\\\\\\\\

Hallo list,

Was anybody successful to run Xth sense software (based on pd) on archlinux
?

pdx 0.43.4

Where I see problems is th 64 bit incompatibility with the xth sense libs,
which are precompiled:

pd-externals/xth-sense-lib/line3.pd_linux:
/home/paum/pd-externals/xth-sense-lib/line3.pd_linux: wrong ELF class:
ELFCLASS32

and TCL errors like this:

(Tcl) INVALID COMMAND NAME: invalid command name ".x7f4e941406b0.c"
while executing
".x7f4e941406b0.c create image 901 776 -image 7f4e94924050PHOTOIMAGE -tags
7f4e94924050PHOTO"
("uplevel" body line 929)
invoked from within
"uplevel #0 $cmds_from_pd"

thanks

fero

--
Marco Donnarumma
New Media + Sonic Arts Practitioner, Performer, Teacher, Director.
Embodied Audio-Visual Interaction Research Team.
Department of Computing, Goldsmiths University of London
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Portfolio: http://marcodonnarumma.com
Research: http://res.marcodonnarumma.com
Director: http://www.liveperformersmeeting.net

--047d7b6dce12f3c55c04dc1f8217
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hi Fero,the errors =
you reported happens only with the new pd-extended 43.4; that is, with pdx =
42.5 everything works fine. In the latest pdx release, the object [=
line3] and the library in which it was included have been removed. These we=
re not maintained by me. So I compiled binaries for Linux ubuntu and mac an=
d included them in the xth-sense-lib.

You can find line3 source here:http://pure-data.svn.sourceforge.net/viewvc/pure-data/branches/p=
d-extended/0.42/externals/nusmuk/line3/

simply compile it and add it to the xth-sense-lib.As for =
the second error, that is a general Pdx bug, apparently related to GOP (gra=
ph on parent) objects. I managed to isolate it and submit a report, but it =
has to be solved yet.

When did you downloaded the Xth Sense software? Very recently I u=
pdated the XS software to a new version which seemed to have worked well ag=
ainst this bug:http://res.marcodonnarumma.com/projects/xth-sense/#download=

it would be great if you could test it out, if you have an older =
version.on a side not=
e, I'm in the process of updating the documentation and the software to=
version 2.0, but I've been slowed down by the above issues appeared wi=
th pdx 43.4. So, hopefully soon this issues should be addressed adequately =
and documented.

hope this helps!best,M\\\\\\\\\\\=
\\\\\\\\\\\\Hallo list,Was anybody successfu=
l to run Xth sense software (based on pd) on archlinux?pdx 0.43=
.4

Where I see problems is th 64 bit incompatibility with the xth sense li=
bs,which are precompiled:pd-externals/xth-sense-lib/line3.pd_li=
nux:/home/paum/pd-externals/xth-sense-lib/line3.pd_linux: wrong ELF cla=
ss:

ELFCLASS32and TCL errors like this:(Tcl) INVALID COMMAND NA=
ME: invalid command name ".x7f4e941406b0.c"=A0 =A0 while exec=
uting".x7f4e941406b0.c create image 901 776 -image 7f4e94924050PHO=
TOIMAGE -tags

7f4e94924050PHOTO"=A0 =A0 ("uplevel" body line 929)=
=A0 =A0 invoked from within"uplevel #0 $cmds_from_pd"=
thanksfero--Marco Donnarumma=
New Media + Sonic Arts Practitioner, Performer, Teacher, Director.

Embodied Audio-Visual Interaction Research Team.Department of Computing=
, Goldsmiths University of London~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Portf=
olio: http://marco=
donnarumma.com

Research: http=
://res.marcodonnarumma.com
Director: http://www.liveperformersmeeting.net

--047d7b6dce12f3c55c04dc1f8217--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

This is the only confirmed message in this thread.
Possibly related messages: