[LAU] XHCI, ALSA and FTU

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Daniel Mack <zonque@...>, Linux Audio Users <linux-audio-user@...>
Date: Saturday, May 4, 2013 - 2:57 pm

--00151761c914af755f04dbe5ae01
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hello all,

The M-Audio Fast-Track Ultra (USB 2) is not recognized by ALSA when plugged
on a USB 3 (XHCI) port on the kernel 3.9 9

I'm trying to figure out where the problem lies to report the issue to the
proper team: is it with XHCI or with ALSA?

In dmesg, this is what happens with the FTU is plugged:
[ 107.461175] usb 3-1: new high-speed USB device number 3 using xhci_hcd
[ 107.481695] usb 3-1: config 1 interface 3 altsetting 0 bulk endpoint 0x7
has invalid maxpacket 8
[ 107.481705] usb 3-1: config 1 interface 3 altsetting 0 bulk endpoint
0x87 has invalid maxpacket 8
[ 107.483384] usb 3-1: New USB device found, idVendor=3D0763, idProduct=3D=
2080
[ 107.483392] usb 3-1: New USB device strings: Mfr=3D1, Product=3D2,
SerialNumber=3D0
[ 107.483398] usb 3-1: Product: Fast Track Ultra
[ 107.483403] usb 3-1: Manufacturer: M-Audio
[ 107.483886] xhci_hcd 0000:04:00.0: ERROR: unexpected command completion
code 0x11.
[ 107.483899] usb 3-1: can't set config #1, error -22

The device is seen by lsusb, but I don't think it really means much:
Bus 003 Device 004: ID 0763:2080 Midiman M-Audio RunTime DFU

aplay -l only doesn't show the sound card, even if I try to modprobe
snd-usb-audio manually:
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: 92HD81B1X5 Analog [92HD81B1X5 Analog=
]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

The same FTU soundcard works on the same machine when plugged on a USB2
port (EHCI).
The Edirol UA-25Ex works on this USB3 port.

What do you guys think?
Is the issue with XHCI or ALSA?

Thanks in advance for the help!

Aur=E9lien

--00151761c914af755f04dbe5ae01
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hello all,The M-Audio Fast-Track=
Ultra (USB 2) is not recognized by ALSA when plugged on a USB 3 (XHCI) por=
t on the kernel 3.9 9=A0I'm tryin=
g to figure out where the problem lies to report the issue to the proper te=
am: is it with XHCI or with ALSA?
In dmesg, this is what happens with the FTU=
is plugged:[ =A0107.461175] usb 3-1: new high-speed =
USB device number 3 using xhci_hcd[ =A0107.481695] usb 3-1: conf=
ig 1 interface 3 altsetting 0 bulk endpoint 0x7 has invalid maxpacket 8
[ =A0107.481705] usb 3-1: config 1 interface 3 altsetting 0 bulk endpo=
int 0x87 has invalid maxpacket 8[ =A0107.483384] usb 3-1: New US=
B device found, idVendor=3D0763, idProduct=3D2080[ =A0107.483392=
] usb 3-1: New USB device strings: Mfr=3D1, Product=3D2, SerialNumber=3D0
[ =A0107.483398] usb 3-1: Product: Fast Track Ultra[ =A0107=
.483403] usb 3-1: Manufacturer: M-Audio[ =A0107.483886] xhci_hcd=
0000:04:00.0: ERROR: unexpected command completion code 0x11.[ =
=A0107.483899] usb 3-1: can't set config #1, error -22
The device is seen by lsusb, but I don't thin=
k it really means much:Bus 003 Device 004: ID 0763:2080 Mi=
diman M-Audio RunTime DFUaplay -l=
only doesn't show the sound card, even if I try to modprobe snd-usb-au=
dio manually:
**** List of PLAYBACK Hardware Devices ****card =
0: MID [HDA Intel MID], device 0: 92HD81B1X5 Analog [92HD81B1X5 Analog]=A0 Subdevices: 1/1=A0 Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]=A0=
Subdevices: 1/1=A0 Subdevice #0: subdevice #0The same FTU soundcard works on the same machi=
ne when plugged on a USB2 port (EHCI).
The Edirol UA-25Ex works on this USB3 port.=
What do you guys=
think?Is the issue with XHCI or ALSA?
Thanks in advance for the help!Aur=E9lien

--00151761c914af755f04dbe5ae01--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] XHCI, ALSA and FTU, Aurélien Leblond, (Sat May 4, 2:57 pm)
Re: [LAU] XHCI, ALSA and FTU, Clemens Ladisch, (Sat May 4, 3:46 pm)
Re: [LAU] XHCI, ALSA and FTU, Felix Homann, (Wed May 8, 10:36 am)
Re: [LAU] XHCI, ALSA and FTU, Aurélien Leblond, (Wed May 8, 11:25 am)
Re: [LAU] XHCI, ALSA and FTU, Felix Homann, (Wed May 8, 1:06 pm)