Re: [LAU] Trouble getting Tascam US-122 to run

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Julien Claassen <julien@...>
Cc: linux-audio-user <linux-audio-user@...>
Date: Monday, May 20, 2013 - 7:36 pm

What is the output of dmesg? If you get something like:

Sequence Error!(hcd_frame=
Most probably some urb of usb-frame is still missing.
Cause could be too long delays in usb-hcd interrupt handling.

then there are problems with urb and usb.

I managed to use my Us122 with this patch:

diff --git a/sound/usb/usx2y/usbusx2yaudio.c b/sound/usb/usx2y/usbusx2yaudio.c
index b376532..9b672a5 100644
--- a/sound/usb/usx2y/usbusx2yaudio.c
+++ b/sound/usb/usx2y/usbusx2yaudio.c
@@ -324,7 +324,7 @@ static void i_usX2Y_urb_complete(struct urb *urb)
usX2Y_error_urb_status(usX2Y, subs, urb);
return;
}
- if (likely((urb->start_frame & 0xFFFF) == (usX2Y->wait_iso_frame & 0xFFFF)))
+ if (likely((urb->start_frame & 0x03FF) == (usX2Y->wait_iso_frame & 0x03FF)))
subs->completed_urb = urb;
else {
usX2Y_error_sequence(usX2Y, subs, urb);

You should also try to set snd-usb.usx2y paramenter nrpacks to 1.

Ciao
Guido

_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Trouble getting Tascam US-122 to run, Julien Claassen, (Fri May 17, 11:20 pm)
Re: [LAU] Trouble getting Tascam US-122 to run, Ralf Mardorf, (Sat May 18, 1:12 am)
Re: [LAU] Trouble getting Tascam US-122 to run, Ralf Mardorf, (Sat May 18, 1:16 am)
Re: [LAU] Trouble getting Tascam US-122 to run, Julien Claassen, (Sat May 18, 1:26 am)
Re: [LAU] Trouble getting Tascam US-122 to run, Ralf Mardorf, (Sat May 18, 1:37 am)
Re: [LAU] Trouble getting Tascam US-122 to run, Julien Claassen, (Sat May 18, 1:40 am)
Re: [LAU] Trouble getting Tascam US-122 to run, Rusty Perez, (Fri May 24, 2:02 pm)
Re: [LAU] Trouble getting Tascam US-122 to run, Rui Nuno Capela, (Fri May 24, 2:52 pm)
Re: [LAU] Trouble getting Tascam US-122 to run, J. Liles, (Fri May 24, 5:26 pm)
Re: [LAU] Trouble getting Tascam US-122 to run, Guido Aulisi, (Mon May 20, 7:36 pm)
Re: [LAU] Trouble getting Tascam US-122 to run, Julien Claassen, (Mon May 20, 4:20 pm)