[LAU] Skype won't work though JACK plugin

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Sunday, April 7, 2013 - 9:55 pm

Hi list,

Redirecting the ALSA default device to JACK seems to be
well-traveled territory,[1,2] nevertheless, I'm not getting
all the behaviors I'd like. Flash works, but Skype doesn't,
and surprisingly Ecasound doesn't do well either (an
interesting data point although hardly a problem.)
Perhaps Skype is trying to work via /dev/dsp?

I'm curious if anyone else is getting better results.

Here are my test results:

aplay test.wav # plays!
aplay -D default test.wav # plays!

mplayer -ao alsa:default test.wav # plays!
mplayer -ao alsa test.wav # plays!

ecasound -i test.wav -o alsa # weird noise after several seconds delay
ecasound -i test.wav -o alsa,default # weird noise after several seconds delay

Flash/Firefox # plays!

skype # "problem with audio playback"

I'm running JACK like this:

jackd -d alsa -d hw:0,0 -r 44100 -H

And I'm using this asoundrc:

pcm.!default {
type plug
slave { pcm "jack" }
}

pcm.jack {
type jack
playback_ports {
0 system:playback_1
1 system:playback_2
}
capture_ports {
0 system:capture_1
1 system:capture_2
}
}

Regards,

Joel

--
Joel Roth
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Skype won't work though JACK plugin, Joel Roth, (Sun Apr 7, 9:55 pm)
Re: [LAU] Skype won't work though JACK plugin, Patrick Shirkey, (Sun Apr 7, 10:57 pm)
Re: [LAU] Skype won't work though JACK plugin, Joel Roth, (Mon Apr 8, 8:02 am)
Re: [LAU] Skype won't work though JACK plugin, Raffaele Morelli, (Mon Apr 8, 8:43 am)
Re: [LAU] Skype won't work though JACK plugin, Joel Roth, (Mon Apr 8, 9:08 am)