Re: [LAU] Trying to run jackd from udev

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Saturday, April 6, 2013 - 5:09 am

@Jeremy
This kinda reminds me of what happens when I run a script from udev. the
rule is for a usb audio device. the script runs an amixer command to set
device name and volume level, then runs jack. if I then run qjackctl
manually it doesn't 'see' jack running. a quick look in qps showed that
jackd is running as root. been banging my head against the wall trying to
figure out how to run the script as my_user instead of root. not sure if
this is in the neighborhood of what you're experiencing.
udev rule:
SUBSYSTEM!="sound", GOTO="90_my_usbaudio_end"
ACTION!="add", GOTO="90_my_usbaudio_end"
DEVPATH=="/devices/pci0000:00/0000:00:1d.2/usb6/6-1/6-1:1.0/sound/card?",
ATTR{id}="UsbAudio", RUN+="/home/my_user/.Amixer/AmixerUsb.sh"
LABEL="90_my_usbaudio_end"
AmixerUsb.sh:
#!/bin/sh
/usr/bin/jackd -dalsa -d hw:3 -r44100 -p1024 -n2
amixer -c 3 -- sset Speaker 10%
tweed

--
View this message in context: http://linux-audio.4202.n7.nabble.com/Trying-to-run-jackd-from-udev-tp83...
Sent from the linux-audio-user mailing list archive at Nabble.com.
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Trying to run jackd from udev, Jeremy Jongepier, (Fri Mar 22, 10:51 pm)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sun Mar 31, 9:05 pm)
Re: [LAU] Trying to run jackd from udev, tweed, (Sat Apr 6, 5:09 am)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sun Apr 14, 12:52 pm)
Re: [LAU] Trying to run jackd from udev, Raphaƫl BOLLEN, (Sat Mar 23, 1:42 pm)
Re: [LAU] Trying to run jackd from udev, Len Ovens, (Sat Mar 23, 3:43 pm)
Re: [LAU] Trying to run jackd from udev, R. Mattes, (Sat Mar 23, 4:05 pm)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sun Mar 24, 1:08 pm)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 5:49 am)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 6:48 am)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sat Mar 23, 8:11 am)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 10:29 am)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sat Mar 23, 12:39 pm)
Re: [LAU] Trying to run jackd from udev, Len Ovens, (Sat Mar 23, 3:30 pm)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 1:02 pm)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sat Mar 23, 1:18 pm)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 10:38 am)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 9:48 am)
Re: [LAU] Trying to run jackd from udev, David, (Sat Mar 23, 4:44 am)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sat Mar 23, 8:10 am)