Re: [LAU] Soundcard DSP2000 is not recognized any more

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Tuesday, April 30, 2013 - 9:28 pm

--047d7beba18273c2ca04db9aafb6
Content-Type: text/plain; charset=ISO-8859-1

Hi,
this is the output from
"/var/log/dmesg" after cold boot.
...
[ 16.921514] usbcore: registered new interface driver snd-usb-audio
[ 16.932523] cannot find the slot for index 0 (range 0-5), error: -16
[ 16.932552] snd_ice1712: probe of 0000:01:06.0 failed with error -16
[ 17.174258] usb 2-1: USB disconnect, device number 2
[ 17.175065] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd fxload rqt 64 rq
160 len 1 ret -108

when I try to load the driver with "sudo modprobe snd_ice1712" nothing
happen in the output of dmesg,
but
"sudo modprobe snd_ice1712"
WARNING: All config files need .conf: /etc/modprobe.d/sound-cards-order, it
will be ignored in a future release.
WARNING: All config files need .conf:
/etc/modprobe.d/sound-cards-order.save, it will be ignored in a future
release.

I have add sound-cards-order to have the soundcard in the right order,
because ubuntu like to mixup the order of the soundcards after every reboot
:-(

This my sound-cards-order in /etc/modprobe.d
options snd_ice1712 index=0
options snd_usb_audio index=1
options snd_usb_audio index=2
options snd_virmidi index=4

Now I have delete this files and try "sudo modprobe snd_ice1712" again. Ok,
now all four LEDs on the DSP2000 are on but the soundcard is not list in
/proc/asound/cards
0 [Device ]: USB-Audio - PnP Audio Device
PnP Audio Device at usb-0000:00:02.0-7, full speed
1 [M4x4 ]: USB-Audio - MidiSport 4x4
M-Audio MidiSport 4x4 at usb-0000:00:02.0-1, full
speed
3 [U0x71040x2202 ]: USB-Audio - USB Device 0x7104:0x2202
USB Device 0x7104:0x2202 at usb-0000:00:02.0-4, full
speed
5 [VirMIDI ]: VirMIDI - VirMIDI
Virtual MIDI Card 1

hm .. ,I try some more reboots

thanks
chris

...

2013/4/30 Clemens Ladisch

> Chris Bungue wrote:

--047d7beba18273c2ca04db9aafb6
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hi, this is the output from"/var/log/dmesg" after cold boot....[=A0=A0 16.921514] =
usbcore: registered new interface driver snd-usb-audio[=A0=A0 16.932523=
] cannot find the slot for index 0 (range 0-5), error: -16
[=A0=A0 16.932552] snd_ice1712: probe of 0000:01:06.0 failed with error -16=
[=A0=A0 17.174258] usb 2-1: USB disconnect, device number 2[=A0=A0 =
17.175065] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd fxload rqt 64 rq 160=
len 1 ret -108
when I try to load the driver with "sudo modprobe snd_ice171=
2" nothing happen in the output of dmesg,but"sudo modprob=
e=A0 snd_ice1712" WARNING: All config files need .conf: /etc/modpr=
obe.d/sound-cards-order, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/sound-cards-order.sav=
e, it will be ignored in a future release.I have add sound-ca=
rds-order to have the soundcard in the right order, because ubuntu like to =
mixup the order of the soundcards after every reboot :-(
This my sound-cards-order in /etc/modprobe.doptions snd_=
ice1712 index=3D0options snd_usb_audio index=3D1options snd_usb_aud=
io index=3D2 options snd_virmidi index=3D4Now =
I have delete this files and try "sudo modprobe snd_ice1712" agai=
n. Ok, now all four LEDs on the DSP2000 are on but=A0 the soundcard is not =
list in
=A0/proc/asound/cards =A00 [Device=A0=A0=A0=A0=A0=A0=A0=A0 ]: USB-Audio=
- PnP Audio Device=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=
=A0=A0=A0=A0 PnP Audio Device at usb-0000:00:02.0-7, full speed=A01 [M4=
x4=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 ]: USB-Audio - MidiSport 4x4=A0=A0=A0=
=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 M-Audio MidiSport 4x=
4 at usb-0000:00:02.0-1, full speed
=A03 [U0x71040x2202=A0 ]: USB-Audio - USB Device 0x7104:0x2202=A0=A0=A0=
=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 USB Device 0x7104:0x=
2202 at usb-0000:00:02.0-4, full speed=A05 [VirMIDI=A0=A0=A0=A0=A0=A0=
=A0 ]: VirMIDI - VirMIDI=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=
=A0=A0=A0=A0=A0=A0 Virtual MIDI Card 1
hm .. ,I try some more rebootst=
hankschris...
2013/4/30 Clemens Ladisch <clemens@lad=
isch.de
>
Chris Bungue wrote:

br>

Are there any messages in the system log (/var/log/messages or the
output of dmesg) after you're trying to load the driver snd-ice1712
(unload it first)?

Regards,
Clemens
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@l=
ists.linuxaudio.org

http://lists.linuxaudio.org/listinfo/linux-audio-user

--047d7beba18273c2ca04db9aafb6--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Soundcard DSP2000 is not recognized any more, Chris Bungue, (Mon Apr 29, 9:05 pm)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Clemens Ladisch, (Tue Apr 30, 7:01 am)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Chris Bungue, (Tue Apr 30, 8:16 am)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Clemens Ladisch, (Tue Apr 30, 11:43 am)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Chris Bungue, (Tue Apr 30, 9:28 pm)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Clemens Ladisch, (Wed May 1, 6:44 am)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Chris Bungue, (Wed May 1, 8:46 am)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Chris Bungue, (Thu May 2, 10:36 am)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Clemens Ladisch, (Thu May 2, 11:34 am)
Re: [LAU] Soundcard DSP2000 is not recognized any more, Chris Bungue, (Tue Apr 30, 10:01 pm)