Re: [LAU] could not start jack - already registered problem

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Friday, April 26, 2013 - 7:30 am

Am 26.04.2013 00:08, schrieb Hartmut Noack:

Now after restart, Jack cannot start with the higher priority either.

:~$ jack_control status
--- status
stopped

PA is *not* running:

:~$ paplay jack_capture_01.wav
Verbindungsfehler: Verbindung verweigert
pa_context_new() fehlgeschlagen: Verbindung verweigert

(Verbindungsfehler is basically: Connection failed)

:~$ pavucontrol
(pavucontrol:2891): Gtk-CRITICAL **: gtk_main_quit: assertion
`main_loops != NULL' failed

And it cannot start:

:~$ pulseaudio
E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
E: [pulseaudio] module.c: Failed to load module "module-alsa-card"
(argument: "device_id="2" name="usb-M_Audio_MobilePre-00-MobilePre"
card_name="alsa_card.usb-M_Audio_MobilePre-00-MobilePre"
namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no
deferred_volume=yes card_properties="module-udev-detect.discovered=1""):
initialization failed.
E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
E: [pulseaudio] module.c: Failed to load module "module-alsa-card"
(argument: "device_id="2" name="usb-M_Audio_MobilePre-00-MobilePre"
card_name="alsa_card.usb-M_Audio_MobilePre-00-MobilePre"
namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no
deferred_volume=yes card_properties="module-udev-detect.discovered=1""):
initialization failed.
E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
E: [pulseaudio] module.c: Failed to load module "module-alsa-card"
(argument: "device_id="2" name="usb-M_Audio_MobilePre-00-MobilePre"
card_name="alsa_card.usb-M_Audio_MobilePre-00-MobilePre"
namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no
deferred_volume=yes card_properties="module-udev-detect.discovered=1""):
initialization failed.
E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
E: [pulseaudio] module.c: Failed to load module "module-alsa-card"
(argument: "device_id="2" name="usb-M_Audio_MobilePre-00-MobilePre"
card_name="alsa_card.usb-M_Audio_MobilePre-00-MobilePre"
namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no
deferred_volume=yes card_properties="module-udev-detect.discovered=1""):
initialization failed.
E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
E: [pulseaudio] module.c: Failed to load module "module-alsa-card"
(argument: "device_id="2" name="usb-M_Audio_MobilePre-00-MobilePre"
card_name="alsa_card.usb-M_Audio_MobilePre-00-MobilePre"
namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no
deferred_volume=yes card_properties="module-udev-detect.discovered=1""):
initialization failed.
E: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
E: [pulseaudio] module.c: Failed to load module "module-alsa-card"
(argument: "device_id="2" name="usb-M_Audio_MobilePre-00-MobilePre"
card_name="alsa_card.usb-M_Audio_MobilePre-00-MobilePre"
namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no
deferred_volume=yes card_properties="module-udev-detect.discovered=1""):
initialization failed.
W: [pulseaudio] module-udev-detect.c: Tried to configure
/devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2:1.0/sound/card2
(alsa_card.usb-M_Audio_MobilePre-00-MobilePre) more often than 5 times
in 10s

Nobody admits to have a grip on any soundcard:

:~$ lsof /dev/snd/*
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
kded4 2261 zettberlin 24u CHR 116,15 0t0 8948 /dev/snd/controlC1
kded4 2261 zettberlin 26u CHR 116,9 0t0 1739 /dev/snd/controlC2
kmix 2552 zettberlin 12u CHR 116,15 0t0 8948 /dev/snd/controlC1
kmix 2552 zettberlin 17u CHR 116,9 0t0 1739 /dev/snd/controlC2

These are just controls... the pcm interfaces are clean.

OK, so I un/replug again....

:~$ tail -f /var/log/syslog
Apr 26 09:20:09 zettberlin-Lenovo-U410 kernel: [ 1252.495471] usb 3-2:
USB disconnect, device number 2
Apr 26 09:20:09 zettberlin-Lenovo-U410 kernel: [ 1252.498259] xhci_hcd
0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep
ffff88021eab1c40
Apr 26 09:20:09 zettberlin-Lenovo-U410 kernel: [ 1252.498269] xhci_hcd
0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep
ffff88021eab1c80
Apr 26 09:20:34 zettberlin-Lenovo-U410 kernel: [ 1277.213574] usb 3-2:
new full-speed USB device number 5 using xhci_hcd
Apr 26 09:20:34 zettberlin-Lenovo-U410 kernel: [ 1277.799954] usb 3-2:
New USB device found, idVendor=0763, idProduct=200f
Apr 26 09:20:34 zettberlin-Lenovo-U410 kernel: [ 1277.799965] usb 3-2:
New USB device strings: Mfr=1, Product=2, SerialNumber=0
Apr 26 09:20:34 zettberlin-Lenovo-U410 kernel: [ 1277.799971] usb 3-2:
Product: MobilePre
Apr 26 09:20:34 zettberlin-Lenovo-U410 kernel: [ 1277.799976] usb 3-2:
Manufacturer: M Audio
Apr 26 09:20:34 zettberlin-Lenovo-U410 mtp-probe: checking bus 3, device
5: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-2"
Apr 26 09:20:34 zettberlin-Lenovo-U410 mtp-probe: bus: 3, device: 5 was
not an MTP device

Now I try to start Jack using Cadence again:

Apr 26 09:22:18 zettberlin-Lenovo-U410 rtkit-daemon[2169]: Successfully
made thread 3046 of process 3046 (n/a) owned by '1000' high priority at
nice level -11.
Apr 26 09:22:18 zettberlin-Lenovo-U410 rtkit-daemon[2169]: Supervising 1
threads of 1 processes of 1 users.
Apr 26 09:22:18 zettberlin-Lenovo-U410 pulseaudio[3046]: [pulseaudio]
pid.c: Stale PID file, overwriting.
Apr 26 09:22:18 zettberlin-Lenovo-U410 pulseaudio[3046]: [pulseaudio]
sink.c: Default and alternate sample rates are the same.
Apr 26 09:22:18 zettberlin-Lenovo-U410 pulseaudio[3046]: [pulseaudio]
module-jack-sink.c: JACK error >Cannot use real-time scheduling
(RR/61)(1: Die Operation ist nicht erlaubt)<
Apr 26 09:22:18 zettberlin-Lenovo-U410 pulseaudio[3046]: [pulseaudio]
module-jack-sink.c: JACK error >JackClient::AcquireSelfRealTime error<
Apr 26 09:22:18 zettberlin-Lenovo-U410 pulseaudio[3046]: [pulseaudio]
source.c: Default and alternate sample rates are the same.
Apr 26 09:22:18 zettberlin-Lenovo-U410 pulseaudio[3046]: [pulseaudio]
module-jack-source.c: JACK error >Cannot use real-time scheduling
(RR/61)(1: Die Operation ist nicht erlaubt)<
Apr 26 09:22:18 zettberlin-Lenovo-U410 pulseaudio[3046]: [pulseaudio]
module-jack-source.c: JACK error >JackClient::AcquireSelfRealTime error<

:~$ uname -a
Linux zettberlin-Lenovo-U410 3.5.0-26-lowlatency #28-Ubuntu SMP PREEMPT
Tue Mar 19 10:32:21 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
:~$ groups
audio dip video plugdev (and others)
:~$ cat /etc/security/limits.d/audio.conf
# Provided by the jackd package.
#
# Changes to this file will be preserved.
#

@audio - rtprio 95
@audio - memlock unlimited

So still I do not know, whatever is registering that handler on the
Reserve Device defined by the PA-package....

Anyone?

>

_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAU] could not start jack - already registered problem, Hartmut Noack, (Fri Apr 26, 7:30 am)