[LAU] could not start jack - already registered problem

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Wednesday, April 24, 2013 - 1:26 pm

Hello,

I run KXStudio on Ubuntu 12.10 on a Lenovo Ideapad with a MAudio Mobile
Pre USB1 interface.

Normaly all this works near perfection but there is a problem starting Jack:

Tue Apr 23 09:58:52 2013: Starting jack server...
Tue Apr 23 09:58:52 2013: JACK server starting in realtime mode with
priority 10
Tue Apr 23 09:58:52 2013: ERROR: cannot register object path
"/org/freedesktop/ReserveDevice1/Audio2": A handler is already
registered for /org/freedesktop/ReserveDevice1/Audio2
Tue Apr 23 09:58:52 2013: ERROR: Failed to acquire device name : Audio2
error : A handler is already registered for
/org/freedesktop/ReserveDevice1/Audio2
Tue Apr 23 09:58:52 2013: ERROR: Audio device hw:MobilePre,0 cannot be
acquired...
Tue Apr 23 09:58:52 2013: ERROR: Cannot initialize driver
Tue Apr 23 09:58:52 2013: ERROR: JackServer::Open failed with -1
Tue Apr 23 09:58:52 2013: ERROR: Failed to open server

I then have to unplug the Mobile Pre, replug it and try again. After 3-4
tries it uses to work so the issue is no show-stopper for me but it is
indeed most annoying.

To be perfectly honest the only thing I really dearly would like to know is:

Tue Apr 23 09:58:52 2013: ERROR: cannot register object path
"/org/freedesktop/ReserveDevice1/Audio2": A handler is already
registered for /org/freedesktop/ReserveDevice1/Audio2

What mechanism has registered the Audio-device, how does that prevent
jack from starting and how can I end this for good?

best regards

HZN

_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAU] Adding a USB device (not working), Len Ovens, (Mon Apr 22, 11:13 pm)
[LAU] could not start jack - already registered problem, Hartmut Noack, (Wed Apr 24, 1:26 pm)