Re: [LAU] Trying to run jackd from udev

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Sunday, March 31, 2013 - 9:05 pm

On 03/22/2013 11:51 PM, Jeremy Jongepier wrote:

The script works now except for one thing, the JACK connections do not
get set up when I boot with the drumpad attached. After having logged in
I still can't set up the connections because either jack_connect and
aj-snapshot complain that JACK is not running while it does run and it
runs as the user I'm logged in with.
This is the script I've fabricated:
https://raw.github.com/AutoStatic/scripts/rpi/rpi/drumpad
I've attached a JACK log of booting with the drumpad attached. JACK
starts successfully, so do all clients but the connections are not set
up. If I then log in and do a jack_lsp -c I get the following back:
pi@jj-rpi ~ $ jack_lsp -c
JACK server not running

Something similar happens when I boot without the drumpad attached and
attach the drumpad when booted. Then I have to wait a while before I can
make the connections (hence the sleep 10 command before calling
aj-snapshot). It'd be nice if I could check somehow if JACK is ready to
make connections.

Anyone any idea? Thanks in advance.

Jeremy

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Trying to run jackd from udev, Jeremy Jongepier, (Fri Mar 22, 10:51 pm)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sun Mar 31, 9:05 pm)
Re: [LAU] Trying to run jackd from udev, tweed, (Sat Apr 6, 5:09 am)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sun Apr 14, 12:52 pm)
Re: [LAU] Trying to run jackd from udev, Raphaƫl BOLLEN, (Sat Mar 23, 1:42 pm)
Re: [LAU] Trying to run jackd from udev, Len Ovens, (Sat Mar 23, 3:43 pm)
Re: [LAU] Trying to run jackd from udev, R. Mattes, (Sat Mar 23, 4:05 pm)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sun Mar 24, 1:08 pm)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 5:49 am)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 6:48 am)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sat Mar 23, 8:11 am)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 10:29 am)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sat Mar 23, 12:39 pm)
Re: [LAU] Trying to run jackd from udev, Len Ovens, (Sat Mar 23, 3:30 pm)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 1:02 pm)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sat Mar 23, 1:18 pm)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 10:38 am)
Re: [LAU] Trying to run jackd from udev, Ralf Mardorf, (Sat Mar 23, 9:48 am)
Re: [LAU] Trying to run jackd from udev, David, (Sat Mar 23, 4:44 am)
Re: [LAU] Trying to run jackd from udev, Jeremy Jongepier, (Sat Mar 23, 8:10 am)