Re: [LAU] Running the guitarix LADSPA plugins on a headless system

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Sean Bolton <sean@...>
Cc: <linux-audio-user@...>
Date: Sunday, February 17, 2013 - 7:31 pm

------PY8DFWH48YY7D49NHLL4MYHK2YIMTW
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
charset=UTF-8

Normaly we use sse2 to set DAZ.
There is a compile option for arm processor=
s in gcc as well, but i havn't add it to the optimazion flag for now.
That =
should need some research.
--
Diese Nachricht wurde von meinem Android Mob=
iltelefon mit WEB.DE Mail gesendet.

Sean Bolton schr=
ieb:

Hi Jeremy and Herman,

On Sat Feb 16 2013, Jeremy Jongepier wrote:

Tried running:
ix.so:guitarix-amp ladspa_guitarix.so:guitarix-fx -v -n
out and RPi becomes unusable. So I fear I have to rule this
:(

CPU maxes out on my system also *when there is no input*. As soon as I
=
feed it some sound, CPU drops to reasonable levels. Looks like there
may be=
a denormal problem in ladspa_guitarix.so:guitarix-amp. This was
using guit=
arix 0.21.0. (I also tried today's guitarix git, and couldn't
reproduce the=
problem, but I also couldn't get anything but a
clean/bypass sound from th=
e amp plugin, so I don't think I actually
tested it.)

-Sean

------PY8DFWH48YY7D49NHLL4MYHK2YIMTW
Content-Type: text/html;
charset=utf-8
Content-Transfer-Encoding: quoted-printable

Normaly we use sse2 to set DAZ.
There is a com=
pile option for arm processors in gcc as well, but i havn't add it to t=
he optimazion flag for now.
That should need some research.
-- =

Diese Nachricht wurde von meinem Android Mobiltelefon mit WEB.DE Mail gese=
ndet.

Sean Bolton <sean@smbo=
lton.com> schrieb:
Hi Jeremy and Herman,On Sat Feb 16 2013, Jeremy J=
ongepier wrote:> Tried running:> DSSI_PATH=3D/usr/lib/lad=
spa jack-dssi-host> ladspa_guitarix=
.so
:guitarix-amp ladspa_guitarix.so:=
guitarix-fx -v -n> -a> > CPU maxes out and RPi b=
ecomes unusable. So I fear I have to rule this > option out :(CPU maxes out on my system also *when there is no input*. As soon a=
s Ifeed it some sound, CPU drops to reasonable levels. Looks like th=
eremay be a denormal problem in ladspa_guitarix.so:guitarix-amp. This wasusing guitarix 0.21.0. (I also=
tried today's guitarix git, and couldn'treproduce the problem, but I=
also couldn't get anything but aclean/bypass sound from the amp plug=
in, so I don't think I actuallytested it.)-Sean
------PY8DFWH48YY7D49NHLL4MYHK2YIMTW--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAU] Running the guitarix LADSPA plugins on a headless ..., Jeremy Jongepier, (Fri Feb 15, 10:07 pm)
Re: [LAU] Running the guitarix LADSPA plugins on a headless ..., brummer-, (Sun Feb 17, 7:31 pm)
Re: [LAU] Running the guitarix LADSPA plugins on a headless ..., Giorgio - Audiophilo, (Sun Feb 17, 10:51 am)
Re: [LAU] Running the guitarix LADSPA plugins on a headless ..., Jeremy Jongepier, (Fri Feb 15, 10:04 pm)