[LAU] ardour3 on debian stable

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
From: Atte <atte@...>
To: <linux-audio-user@...>
Date: Thursday, December 12, 2013 - 10:10 pm

Hi

I'm runing crunchbang linux, which essentially is debian stable. I'm
having trouble getting ardour3 working, tried both the source tarball,
checking out from git and the paid-for download from ardour.org. Let's
take the later:

atte@skagen:~/software/ardour3$ sudo dpkg -i ardour3_3.5.74~dfsg-1_i386.deb
[sudo] password for atte:
Selecting previously unselected package ardour3.
(Reading database ... 208603 files and directories currently installed.)
Unpacking ardour3 (from ardour3_3.5.74~dfsg-1_i386.deb) ...
dpkg: dependency problems prevent configuration of ardour3:
ardour3 depends on libc6 (>= 2.17); however:
Version of libc6:i386 on system is 2.13-38.
ardour3 depends on libfftw3-double3; however:
Package libfftw3-double3 is not installed.
ardour3 depends on libfftw3-single3; however:
Package libfftw3-single3 is not installed.
ardour3 depends on libflac8 (>= 1.3.0); however:
Version of libflac8:i386 on system is 1.2.1-6.
ardour3 depends on libfontconfig1 (>= 2.11); however:
Version of libfontconfig1:i386 on system is 2.9.0-7.1.
ardour3 depends on libglibmm-2.4-1c2a (>= 2.36.2); however:
Version of libglibmm-2.4-1c2a:i386 on system is 2.32.1-1.
ardour3 depends on libpango-1.0-0 (>= 1.14.0); however:
Package libpango-1.0-0 is not installed.
ardour3 depends on libpangocairo-1.0-0 (>= 1.14.0); however:
Package libpangocairo-1.0-0 is not installed.
ardour3 depends on libpangoft2-1.0-0 (>= 1.14.0); however:
Package libpangoft2-1.0-0 is not installed.

dpkg: error processing ardour3 (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for shared-mime-info ...
Processing triggers for menu ...
Errors were encountered while processing:
ardour3

Hmmm. So ardour3 is dependent libs with higher version numbers than my
system provides. Needless to say, I don't want to break my system doing
this, so in stead of just poking around, I'd rather ask here:

What are the steps needed to safely install the dependencies for ardour3
on a debian stable system?

Thanks in advance for any help!

--
Atte

http://atte.dk http://modlys.dk
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] ardour3 on debian stable, Atte, (Thu Dec 12, 10:10 pm)
Re: [LAU] ardour3 on debian stable, Russell Hanaghan, (Fri Dec 13, 8:20 pm)
Re: [LAU] ardour3 on debian stable, Filipe Coelho, (Fri Dec 13, 8:29 pm)
Re: [LAU] ardour3 on debian stable, Russell Hanaghan, (Fri Dec 13, 9:17 pm)
Re: [LAU] ardour3 on debian stable, Milan Lazecky, (Fri Dec 13, 8:53 am)
Re: [LAU] ardour3 on debian stable, Ken Restivo, (Sat Dec 14, 6:45 am)
Re: [LAU] ardour3 on debian stable, Paul Davis, (Thu Dec 12, 10:33 pm)
Re: [LAU] ardour3 on debian stable, Atte, (Fri Dec 13, 9:15 am)
Re: [LAU] ardour3 on debian stable, Ralf Mardorf, (Thu Dec 12, 10:53 pm)