[LAU] Sound Devices USBPre2, UAC2 status

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
From: <shal@...>
To: <linux-audio-user@...>
Date: Friday, January 4, 2013 - 7:31 pm

Hi,

Some old posts exist about the UAC2 support for the Sound Devices USBPre2 but some problem remains.
The current status is that this sound card is supported as a USB 1.1 card in high-speed mode.
But this card is not seen as a Usb Audio Class 2 on Linux. On Mac OS X this card is recognized as UAC2.

My principal problem is that the "device descriptor" provided by the card is always a USB1.1 class
There is two modes of boot for the card (pressing the "1" button, the card is in full speed mode, without pressing in UAC2 mode)
There is only one difference between these two modes in the lsusb -v : the "bInterval" go to 4 from 1.

This is already view by Clemens on:
http://lists.linuxaudio.org/pipermail/linux-audio-user/2011-October/0812...

In this another post, we can seen:

Bernardo Barros wrote:

Strange, I have never 2 on bNumConfigurations ! Somebody can test it on its card ?
This is perhaps my problem, my card only provides one "Configuration Descriptor".
The second one is certainly the UAC2 "Configuration Descriptor".

The lsusb without 1 pressed : http://pastebin.com/8yjjASv7
The lsusb with 1 pressed : http://pastebin.com/pGFdjR4K
The usbmon trace of the insertion of the usbpre2 (without "1") : http://pastebin.com/pySC4Age

This sound card is great, it is very disappointing to not be able to used it with all functionnalities.

I search help in order to debug this problem.
I am devlopper, I can test kernel patches without problem.

Thank for any idea (or patch).

Olivier
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Sound Devices USBPre2, UAC2 status, , (Fri Jan 4, 7:31 pm)
Re: [LAU] Sound Devices USBPre2, UAC2 status, alexander, (Mon Jan 21, 3:00 pm)
Re: [LAU] Sound Devices USBPre2, UAC2 status, alexander, (Fri Jan 25, 10:37 pm)
Re: [LAU] USB2 Audio, PreSonus Audiobox 1818VSL, Robin Gareus, (Tue Jan 15, 8:34 pm)
Re: [LAU] USB2 Audio, PreSonus Audiobox 1818VSL, Louis Gorenfeld, (Tue Jan 15, 10:44 pm)
Re: [LAU] Sound Devices USBPre2, UAC2 status, alexander, (Mon Jan 7, 5:28 pm)
Re: [LAU] Sound Devices USBPre2, UAC2 status, Hans Wilmers, (Thu Jan 10, 12:24 pm)
Re: [LAU] Sound Devices USBPre2, UAC2 status, Hans Wilmers, (Thu Jan 10, 9:11 pm)
Re: [LAU] Sound Devices USBPre2, UAC2 status, Hans Wilmers, (Thu Jan 10, 10:24 pm)
Re: [LAU] Sound Devices USBPre2, UAC2 status, alexander, (Mon Jan 14, 9:20 pm)