Re: [LAU] MIDI keyboard not recognized

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
From: jy <jypllx@...>
To: <linux-audio-user@...>
Date: Monday, September 17, 2012 - 8:23 pm

--20cf3068481981b03f04c9eb8c8f
Content-Type: text/plain; charset=ISO-8859-1

Hi all,

I re-read the whole thread. So basically, for now and looking at the
various logs, there's something ALSA related that's not clear but I'm not
sure wether it's modules or something else.

This is my kernel version : Linux 3.2.0-23-lowlatency-pae #31-Ubuntu SMP
PREEMPT Wed Apr 11 04:07:36 UTC 2012 i686 i686 i386 GNU/Linux

Here's basically what we know so far :
* keyboard is detected, it's present in both lsusb and amidi -l. Qjackctl
lists it as hw:1 in the interface list.
* snd_usb_audio is present and loaded
* snd_seq_midi is missing (as says modinfo) but some people say that it's
not necessary. I tried to load it manually (sudo modprobe snd_seq_midi) but
a fatal error occurs saying there's no such module. After a quick look, I
found that I have snd-seq-midi-emul and snd-seq-midi-event modules. I'm
deducing from these names that snd-seq-midi is actually installed but it
might have changed name slightly.
* usbcore is also missing. I tried to load it manually (sudo modprobe
usbcore) but nothing happens. Looking at the ALSA pages, there seems to be
no usbcore module but a usbaudio one (supposed to handle both audio and
MIDI hardware) which is not present. See http://alsa.opensrc.org/Usb-audio
* when running jack with no midi driver and use a2jmidid -e instead, the
keyboard does not appear in the MIDI tab.

Here's what I discovered after a little search :
* There's seems to be something wrong with my audio card setup. I can see
three devices with aplay -l but only 2 in the qjackctl settings, one of
them with a different name. I might wanna try to reinstall the audio
drivers Realtek ACL888.

So basically, the strangest thing is probably that ALSA properly recognizes
the keyboard (amidi -l sees it) whereas a2jmidid -e does not.

Any idea on this one ? Where would a2jmidid go look for ALSA midi ports ?

Thank !!

jy

2012/9/14 jy

> Hi all,

--20cf3068481981b03f04c9eb8c8f
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hi all,I re-read the whole thread. So basically, for now and lookin=
g at the various logs, there's something ALSA related that's not cl=
ear but I'm not sure wether it's modules or something else.

This is my kernel version : Linux 3.2.0-23-lowlatency-pae #31-Ubuntu SMP PR=
EEMPT Wed Apr 11 04:07:36 UTC 2012 i686 i686 i386 GNU/LinuxHere&#39=
;s basically what we know so far :=A0* keyboard is detected, it's p=
resent in both lsusb and amidi -l. Qjackctl lists it as hw:1 in the interfa=
ce list.

=A0* snd_usb_audio is present and loaded
=A0* snd_seq_midi is missing (as says modinfo) but some people say that it&=
#39;s not necessary. I tried to load it manually (sudo modprobe snd_seq_mid=
i) but a fatal error occurs saying there's no such module. After a quic=
k look, I found that I have snd-seq-midi-emul and snd-seq-midi-event module=
s. I'm deducing=20
from these names that snd-seq-midi is actually installed but it might=20
have changed name slightly.=A0* usbcore is also missing. I tried to loa=
d it manually (sudo modprobe usbcore) but nothing happens. Looking at the A=
LSA pages, there seems to be no usbcore module but a usbaudio one (supposed=
to handle both audio and MIDI hardware) which is not present. See http://alsa.opensrc.org/Usb-audio

=A0* when running jack with no midi driver and use a2jmidid -e instead, the=
keyboard does not appear in the MIDI tab.
Here's what I discovered after a little search :=A0* There'=
s seems to be something wrong with my audio card setup. I can see three dev=
ices with aplay -l but only 2 in the qjackctl settings, one of them with a =
different name. I might wanna try to reinstall the audio drivers Realtek AC=
L888.

So basically, the strangest thing is probably that ALSA properly re=
cognizes the keyboard (amidi -l sees it) whereas a2jmidid -e does not.<=
br>Any idea on this one ? Where would a2jmidid go look for ALSA midi ports =
?

Thank !!jy2012/9/14 jy <=
span dir=3D"ltr"><=
jypllx@gmail.com
>

Hi all,reading all your answers, i'm not sure what the problem =
is ! :)I'll be away for the week-end so I'll look into it early=
next week and reread all this thread one reply at a time !Cheers !

jy2012/9/13 =
Ralf Mardorf <ralf.mardorf@alice-dsl.net>

On Thu, 2012-09-13 at 22:23 +0200, Ralf=
Mardorf wrote:

QJackCtl tab Misc, "[x] Enable ALSA sequencer support" is e=
nabled.

spinymouse@precise:~$ jackd -V
jackdmp 1.9.8

_______________________________________________
Linux-audio-user mailing list
=
Linux-audio-user@lists.linuxaudio.org

http://lists.linuxaudio.org/listinfo/linux-audio-user

--20cf3068481981b03f04c9eb8c8f--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAU] MIDI keyboard not recognized, jy, (Thu Sep 13, 10:33 am)
Re: [LAU] MIDI keyboard not recognized, Nigel Henry, (Thu Sep 13, 1:16 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Thu Sep 13, 5:25 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Thu Sep 13, 6:15 pm)
Re: [LAU] MIDI keyboard not recognized, Nigel Henry, (Thu Sep 13, 7:37 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Thu Sep 13, 8:32 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Thu Sep 13, 7:07 pm)
Re: [LAU] MIDI keyboard not recognized, Jeremy Jongepier, (Thu Sep 13, 8:14 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Thu Sep 13, 8:22 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Thu Sep 13, 8:32 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Thu Sep 13, 8:35 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Fri Sep 14, 1:43 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Mon Sep 17, 8:23 pm)
Re: [LAU] MIDI keyboard not recognized, Pedro Lopez-Cabanillas, (Tue Sep 18, 5:27 am)
Re: [LAU] MIDI keyboard not recognized, jy, (Tue Sep 18, 5:08 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Tue Sep 18, 5:16 pm)
Re: [LAU] MIDI keyboard not recognized, Pedro Lopez-Cabanillas, (Tue Sep 18, 5:36 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Tue Sep 18, 5:52 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Tue Sep 18, 7:46 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Mon Sep 17, 8:39 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Mon Sep 17, 9:21 pm)
Re: [LAU] MIDI keyboard not recognized, Jeremy Jongepier, (Mon Sep 17, 8:28 pm)
Re: [LAU] MIDI keyboard not recognized, Nigel Henry, (Thu Sep 13, 7:12 pm)
Re: [LAU] MIDI keyboard not recognized, david, (Thu Sep 13, 7:49 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Thu Sep 13, 8:08 pm)
Re: [LAU] MIDI keyboard not recognized, Ralf Mardorf, (Thu Sep 13, 1:36 pm)