Re: [LAU] hdsp not happy with recent kernels

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Peter Lutek <peter@...>
Cc: <linux-audio-user@...>
Date: Thursday, September 13, 2012 - 4:56 pm

--e89a8ff1c5842557f404c9982ecd
Content-Type: text/plain; charset=ISO-8859-1

Hi Peter!

I'm using a Multiface II, with Cardbus adapter on a relatively old laptop
(Acer TM 5720).
Kernel @ 3.4.4-rt14-1-rt
Alsa @ 1.0.25

No issues running, although I have seen the "hardware monitoring disabled"
warning before (on a different install, never on this install.)

Happily runs for hours on end at 5ms, only Xruns are in-audiable and occur
only when under extreme DSP load (95% +)

Incidentally I'm also using a Wacom (Bamboo P&T) with the RT kernel,
working fine too :D

I can post details of my machine etc if you have anthing you'd like to know.
Best! -Harry

On Thu, Sep 13, 2012 at 5:29 PM, Peter Lutek wrote:

> greetings!

--e89a8ff1c5842557f404c9982ecd
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hi Peter!I'm using a Multiface II, with Cardbus adapter on a re=
latively old laptop (Acer TM 5720). Kernel @ 3.4.4-rt14-1-rtAlsa @ =
1.0.25No issues running, although I have seen the "hardware mo=
nitoring disabled" warning before (on a different install, never on th=
is install.)
Happily runs for hours on end at 5ms, only Xruns are in-audiable and oc=
cur only when under extreme DSP load (95% +)Incidentally I'm al=
so using a Wacom (Bamboo P&T) with the RT kernel, working fine too :D
I can post details of my machine etc if you have anthing you'd like=
to know.Best! -HarryOn Thu, Sep=
13, 2012 at 5:29 PM, Peter Lutek <peter@peterlutek.com> =
wrote:
greetings!

perhaps some of you use RME hdsp hardware. i'm wondering if you're =
running into
issues like mine with recent kernels....

i've got an hdsp multiface hanging off an expresscard adapter in a T520=
thinkpad.
here's what's going on:

hdspmixer locks up soon after starting, saying, "HwDep ioctl failed. M=
etering
stopped"

once that has happened, if i try to start jack, i get this:

plutek@palnote:~$ jackd -dalsa -D -Phw:0,0 -Chw:0,0
jackdmp 1.9.9
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2012 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
control device hw:0
control device hw:0
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0,0|hw:0,0|1024|2|48000|0|0|nomon|swmeter|-|32b=
it
control device hw:0
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture=
-only mode
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server

alternately, if i start jack after a reboot *without* first starting hdspmi=
xer,
it runs for a few minutes (variable), then fails thusly:

plutek@palnote:~$ jackd -dalsa -D -Phw:0,0 -Chw:0,0
jackdmp 1.9.9
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2012 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
control device hw:0
control device hw:0
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0,0|hw:0,0|1024|2|48000|0|0|nomon|swmeter|-|32b=
it
control device hw:0
configuring for 48000Hz, period =3D 1024 frames (21.3 ms), buffer =3D 2 per=
iods
ALSA: final selected sample format for capture: 32bit integer little-endian=

ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endia=
n
ALSA: use 2 periods for playback
ALSA: poll time out, polled for 31999183 usecs
JackAudioDriver::ProcessAsync: read error, stopping...

i'm on the aptosid distribution.
alsa-tools-gui is 1.0.25-2
although running jackd says "jackdmp 1.9.9", my installed debian =
package is
jackd2 1.9.8~dfsg.4+20120529git007cdc37-4
alsa is 1.0.23+dfsg-4

and here's the clincher:

kernels up to and including 3.1-6 make it all work fine (with the same vers=
ions
of other things as listed above). however, kernels 3.2.0-3 and higher all c=
ause
the issues reported above.

so, i guess the bottom-line question is whether other folks are running hds=
p
hardware successfully on 3.2 or more recent kernels, or whether we're a=
ll stuck
at 3.1 for now?

amusing side-note: i'm trying to use a wacom tablet, which is fine with=
the 3.2
and higher kernels, but not with the 3.1 -- haha!!

please let me know if you have any relevant observations on this; it'd =
be nice to
have some reassurance that my multiface isn't seeing the beginning of t=
he end!

thanks in advance.... cheers!
.pltk.
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@l=
ists.linuxaudio.org

http://lists.linuxaudio.org/listinfo/linux-audio-user

--e89a8ff1c5842557f404c9982ecd--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] hdsp not happy with recent kernels, Peter Lutek, (Thu Sep 13, 4:29 pm)
Re: [LAU] hdsp not happy with recent kernels, Michał Koziarski, (Sat Sep 29, 9:41 pm)
Re: [LAU] hdsp not happy with recent kernels, Peter Lutek, (Mon Oct 1, 6:18 pm)
Re: [LAU] [SOLVED] hdsp not happy with recent kernels, Michał Koziarski, (Mon Oct 1, 9:52 pm)
Re: [LAU] hdsp not happy with recent kernels, Fons Adriaensen, (Thu Sep 13, 9:30 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 8:34 pm)
Re: [LAU] hdsp not happy with recent kernels, Brett McCoy, (Thu Sep 13, 4:56 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 8:34 pm)
Re: [LAU] hdsp not happy with recent kernels, Peter Lutek, (Thu Sep 13, 8:14 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 8:29 pm)
Re: [LAU] hdsp not happy with recent kernels, Fernando Lopez-Lezcano, (Thu Sep 13, 8:45 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 8:56 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 9:12 pm)
Re: [LAU] hdsp not happy with recent kernels, Fernando Lopez-Lezcano, (Thu Sep 13, 9:08 pm)
Re: [LAU] hdsp not happy with recent kernels, Len Ovens, (Thu Sep 13, 10:52 pm)
Re: [LAU] hdsp not happy with recent kernels, Paul Davis, (Fri Sep 14, 12:00 am)
Re: [LAU] hdsp not happy with recent kernels, Len Ovens, (Fri Sep 14, 5:34 am)
[LAU] OT: hdsp not happy with recent kernels, Ralf Mardorf, (Fri Sep 14, 7:22 am)
Re: [LAU] OT: hdsp not happy with recent kernels, Len Ovens, (Fri Sep 14, 10:18 pm)
Re: [LAU] OT: hdsp not happy with recent kernels, Ralf Mardorf, (Fri Sep 14, 10:28 pm)
Re: [LAU] OT: hdsp not happy with recent kernels, Len Ovens, (Fri Sep 14, 11:03 pm)
Re: [LAU] OT: hdsp not happy with recent kernels, Chris Bannister, (Sun Sep 23, 10:19 pm)
Re: [LAU] OT: hdsp not happy with recent kernels, Kaj Ailomaa, (Fri Sep 14, 11:07 pm)
[LAU] OT: hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 11:38 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 9:29 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 9:21 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 9:49 pm)
Re: [LAU] hdsp not happy with recent kernels, Ralf Mardorf, (Thu Sep 13, 8:32 pm)
Re: [LAU] hdsp not happy with recent kernels, Harry van Haaren, (Thu Sep 13, 4:56 pm)
Re: [LAU] hdsp not happy with recent kernels, Peter Lutek, (Thu Sep 13, 5:06 pm)
Re: [LAU] hdsp not happy with recent kernels, Peter Lutek, (Thu Sep 13, 6:27 pm)
Re: [LAU] hdsp not happy with recent kernels, david, (Thu Sep 13, 7:31 pm)
Re: [LAU] hdsp not happy with recent kernels, Peter Lutek, (Thu Sep 13, 6:42 pm)
Re: [LAU] hdsp not happy with recent kernels, Fernando Lopez-Lezcano, (Thu Sep 13, 8:41 pm)