Re: [LAU] MIDI keyboard not recognized

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Monday, September 10, 2012 - 3:05 pm

On Monday 10 September 2012 09:50, jy wrote:

Yeh, that's another little problem.

Lets have a go at the USB problem. Your lsusb shows a webcam. I can't find any
details about it on the web, but presume there's a mike on the card which
will need to use snd_usb_audio. I'm guessing there may be a conflict where
both usb audio devices are trying to use snd_usb_audio in the same card slot.
So first thing to try is to remove the midi keyboard from the machine, then
see if anything turns up in /proc/asound/cards, like hopefully the webcam
mike using snd_usb_audio as card1.

If by some miracle it does, you need to add an options line
in /etc/modprobe,d/options to cover both devices, the webcam mike and the
midi keyboard.

Run lsusb -n and you should see the Vid/Pid's for both devices in hex. Add
the following options line, removing the snd_usb_audio options line I gave
you yesterday but leaving the one for the soundcard.

[courtesy of a post on Linux Musicians forum]
Look at the output of “lsusb” and “lsusb -n” for the vendor/product IDs of the
devices, then specify these IDs in the vid and/or pid options, in
hexadecimal. For exampe, if your first USB device has IDs 0123:4567 and the
second 89ab:cdef, use the line

options snd-usb-audio index=2,3 pid=0x4567,0xcdef

You will need to change the 4567 and cdef for whatever the pid's are for the
webcam and midi keyboard.

Right. Go for it! He says, not holding out much hope.

Nigel.

> > _______________________________________________

_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAU] MIDI keyboard not recognized, Nigel Henry, (Sun Sep 9, 8:19 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Mon Sep 10, 7:51 am)
Re: [LAU] MIDI keyboard not recognized, Nigel Henry, (Mon Sep 10, 3:05 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Mon Sep 10, 5:09 pm)
Re: [LAU] MIDI keyboard not recognized, Paul Davis, (Mon Sep 10, 5:55 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Mon Sep 10, 8:41 pm)
Re: [LAU] MIDI keyboard not recognized, Brett McCoy, (Mon Sep 10, 9:13 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Tue Sep 11, 7:38 am)
Re: [LAU] MIDI keyboard not recognized, Pedro Lopez-Cabanillas, (Tue Sep 11, 8:57 am)
Re: [LAU] MIDI keyboard not recognized, jy, (Thu Sep 13, 5:39 am)
Re: [LAU] MIDI keyboard not recognized, Jeremy Jongepier, (Thu Sep 13, 7:11 am)
Re: [LAU] MIDI keyboard not recognized, jy, (Thu Sep 13, 7:31 am)
Re: [LAU] MIDI keyboard not recognized, Jeremy Jongepier, (Thu Sep 13, 7:41 am)
Re: [LAU] MIDI keyboard not recognized, jy, (Thu Sep 13, 5:23 pm)
Re: [LAU] MIDI keyboard not recognized, Jeremy Jongepier, (Thu Sep 13, 7:53 pm)
Re: [LAU] MIDI keyboard not recognized, david, (Thu Sep 13, 7:55 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Tue Sep 11, 9:08 am)
Re: [LAU] MIDI keyboard not recognized, jy, (Mon Sep 10, 8:56 pm)
Re: [LAU] MIDI keyboard not recognized, Paul Davis, (Mon Sep 10, 8:57 pm)
Re: [LAU] MIDI keyboard not recognized, Paul Davis, (Sun Sep 9, 8:25 pm)
Re: [LAU] MIDI keyboard not recognized, Nigel Henry, (Mon Sep 10, 2:31 pm)
Re: [LAU] MIDI keyboard not recognized, jy, (Mon Sep 10, 2:40 pm)