Re: [LAU] [LAD] [ANN] Radium V0.65.0

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>, <linux-audio-dev@...>
Date: Friday, July 6, 2012 - 6:59 am

Alexandre Prokoudine:

Yes, in the makefile you can specify USE_QT4 instead of USE_QT3. It
doesn't work
right now, but it did a few weeks ago. Problem with QT4 is that copying
pixmap
to widget (bitblt) was so horribly slow. (And I did turn off double
buffering
plus some other other options, but it only helped a little bit.)

I don't know what the problem was, maybe my X setup is too old.

It's not surprising that bitblt is a little bit slower in QT4 since
their QPixmap is not a wrapper around the X Pixmap anymore. Maybe
that's the whole explanation. It was usable, but not very nice compared
to QT3.

File requesters and the FX selector are always made with QT4 though.
:-)
(IOW. Radium requires both QT3 and QT4 in the default setup.)

_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAU] [LAD] [ANN] Radium V0.65.0, Kjetil Matheussen, (Fri Jul 6, 6:59 am)
Re: [LAU] [LAD] [ANN] Radium V0.65.0, Kjetil Matheussen, (Fri Jul 6, 7:41 am)
Re: [LAU] [LAD] [ANN] Radium V0.65.0, Alexandre Prokoudine, (Fri Jul 6, 7:02 am)