Re: [LAU] Segfault using zita-j2a

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Jannis Achstetter <jannis_achstetter@...>
Cc: <linux-audio-user@...>
Date: Thursday, October 25, 2012 - 8:57 pm

On Thu, Oct 25, 2012 at 07:37:24PM +0200, Jannis Achstetter wrote:

> In my last mail I forgot: zresample works perfectly fine on the files

Yes and no. The zresample app uses the Resampler class,
while zita-ajbridge uses VResampler. The two share some
code, but they are different classes. Could you try the
zretune app that comes with the latest release of zita-
resamper ? This is using the VResampler class.

> warning: Could not load shared library symbols for linux-vdso.so.1.

I've no idea what linux-vdso.so is ...

This may be unrelated, but I also see frequent errors on
the ALSA device in the valgrind output. Could you test
the device with the alsa_loopback app that comes with
zita-alsa-pcmi, using the same parameters as you'd use
for zita-a2j ?

I suspect this is some 64-bit related problem...

Ciao,

--
FA

A world of exhaustive, reliable metadata would be an utopia.
It's also a pipe-dream, founded on self-delusion, nerd hubris
and hysterically inflated market opportunities. (Cory Doctorow)

_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 2:54 pm)
Re: [LAU] Segfault using zita-j2a, Robin Gareus, (Thu Oct 25, 3:23 pm)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Thu Oct 25, 3:51 pm)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 5:37 pm)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Thu Oct 25, 8:57 pm)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 9:37 pm)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Fri Oct 26, 7:37 am)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Fri Oct 26, 10:27 am)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Fri Oct 26, 11:57 am)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Sat Oct 27, 6:23 pm)
Re: [LAU] Segfault using zita-j2a, Fons Adriaensen, (Fri Oct 26, 7:59 am)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 4:52 pm)
Re: [LAU] Segfault using zita-j2a, Jannis Achstetter, (Thu Oct 25, 3:49 pm)
Re: [LAU] Segfault using zita-j2a, Robin Gareus, (Thu Oct 25, 3:53 pm)