Re: [LAU] starting pd-extended 0.42.5

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Marco Donnarumma <devel@...>
Cc: <linux-audio-user@...>
Date: Sunday, August 21, 2011 - 5:42 pm

--001517447ad0a83e9804ab077d46
Content-Type: text/plain; charset=ISO-8859-1

Hmmm.....

Not too sure why this doesn't work. However I looked in
/usr/share/applications and "vim'd" pd-extended.desktop and got this:

[Desktop Entry]
Encoding=UTF-8
Name=Pd-extended
GenericName=Pure Data
Comment=Visual dataflow programming platform for multimedia
Comment[ca]=Plataforma de programaci<97> visual per aplicacions
multim<8f>dia
Comment[de]=Grafische Datenflussprogrammierung f<9f>r Multimedia
Comment[es]=Plataforma de programaci<97>n visual para aplicaciones
multimedia
Comment[fr]=Plateforme de programmation visuelle pour applications
multim<8e>dia
Comment[it]=Piattaforma di programmazione visuale per applicazioni
multimedia
Comment[pt]=Plataforma de programa<8d><8b>o visuais para multimedia
Exec=pasuspender -- /usr/bin/pdextended -alsa %F
Terminal=false
Type=Application
Icon=pd
TryExec=pdextended
Categories=AudioVideo;Audio;Video;Development
MimeType=text/x-puredata;application/x-maxmsp;text/x-maxmsp;
StartupNotify=false
~

.....Notice the bit in yellow? I'm wondering if that's colliding with
Jack's settings somehow.

(I tried commenting that part out and starting pd and it wouldn't even
start).

If I start pd via the terminal, say, like this: pdextended -jack channels 2
/home/aaron/Desktop/AaronsFiddleSplit.pd

.....I still have to select "JacK' in my media settings (within PD) so it's
not selected by default which one would think would be the case as that's
the flag I sent it, correct?

Either way, my audio settings don't seem to work in pd.

Here's the messages I get before selecting Jack:

error: channels: can't open
error: 2: can't open
fiddle version 1.1 TEST4

Then I'll click on DIO Errors and get this:

seconds ago error type
2.35 unknown
2.35 unknown
audio I/O error history:
seconds ago error type
3.10 unknown
3.10 unknown
audio I/O error history:
seconds ago error type
3.57 unknown
3.57 unknown

Then I'll select Jack in the media settings of pd and click DIO and get
this:

audio I/O error history:
seconds ago error type
1.30 unknown
2.32 unknown
109.83 unknown
109.83 unknown

Oddly enough, within Jack, all of my connections are gone. So basically it
looks like there are no readable or writable clients to connect to.

Even odder though is the fact that Jack is still running alright as I can
watch a youtube video and audio still works.

Thanks for any input.

-Aaron

On Sun, Aug 21, 2011 at 5:32 AM, Marco Donnarumma wrote:

> Hi,

--001517447ad0a83e9804ab077d46
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hmmm.....Not too sure why this doesn't work.=A0 However I looke=
d in /usr/share/applications and "vim'd" pd-extended.desktop =
and got this:[Desktop Entry]Encoding=3DUTF-8Name=3DPd-exten=
ded
GenericName=3DPure DataComment=3DVisual dataflow programming platform f=
or multimediaComment[ca]=3DPlataforma de programaci<97> visual pe=
r aplicacions multim<8f>diaComment[de]=3DGrafische Datenflussprog=
rammierung f<9f>r Multimedia
Comment[es]=3DPlataforma de programaci<97>n visual para aplicaciones =
multimediaComment[fr]=3DPlateforme de programmation visuelle pour appli=
cations multim<8e>diaComment[it]=3DPiattaforma di programmazione =
visuale per applicazioni multimedia
Comment[pt]=3DPlataforma de programa<8d><8b>o visuais para mult=
imediaExec=3Dpasus=
pender -- /usr/bin/pdextended -alsa %FTerminal=3DfalseType=
=3DApplication
Icon=3DpdTryExec=3DpdextendedCategories=3DAudioVideo;Audio;Video;De=
velopmentMimeType=3Dtext/x-puredata;application/x-maxmsp;text/x-maxmsp;=
StartupNotify=3Dfalse~=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=
=A0=A0=A0=A0 .....Notice the bit in yellow?=A0 I'm wondering if=
that's colliding with Jack's settings somehow.
(I tried commenting that part out and starting pd and it wouldn't e=
ven start).If I start pd via the terminal, say, like this:=A0 pdext=
ended -jack channels 2 /home/aaron/Desktop/AaronsFiddleSplit.pd ...=
..I still have to select "JacK' in my media settings (within PD) s=
o it's not selected by default which one would think would be the case =
as that's the flag I sent it, correct?
Either way, my=A0 audio settings don't seem to work in pd.H=
ere's the messages I get before selecting Jack:error: channels: can't openerror: 2: can't op=
en
fiddle version 1.1 TEST4Then I'll click on DIO Errors and=
get this:seconds ago=A0=A0=A0 er=
ror type=A0=A0=A0=A0 2.35=A0=A0=A0 unknown=A0=A0=A0=A0 2.35=A0=A0=
=A0 unknownaudio I/O error history:
seconds ago=A0=A0=A0 error type=A0=A0=A0=A0 3.10=A0=A0=A0 unknown=
=A0=A0=A0=A0 3.10=A0=A0=A0 unknownaudio I/O error history:seconds a=
go=A0=A0=A0 error type=A0=A0=A0=A0 3.57=A0=A0=A0 unknown=A0=A0=A0=
=A0 3.57=A0=A0=A0 unknownThen I'll select Jack in the med=
ia settings of pd and click DIO and get this:
audio I/O error history:seconds a=
go=A0=A0=A0 error type=A0=A0=A0=A0 1.30=A0=A0=A0 unknown=A0=A0=A0=
=A0 2.32=A0=A0=A0 unknown=A0=A0 109.83=A0=A0=A0 unknown=A0=A0 109.8=
3=A0=A0=A0 unknownOddly enough, within Jack, all of my connec=
tions are gone.=A0 So basically it looks like there are no readable or writ=
able clients to connect to.
Even odder though is the fact that Jack is still running alright as I c=
an watch a youtube video and audio still works.Thanks for any input=
.-AaronOn Sun, Aug 2=
1, 2011 at 5:32 AM, Marco Donnarumma <devel@thesaddj.com> wrote:
Hi,AFAIK, no compilation flags are needed to enable jack sup=
port for pd-ext.
http://puredata.info/docs/developer/BuildingPdExtended
After starting qjack, Have you already tried launching =
pd from terminal withpdextended -jack channels 2 <your patch =
name>?I don't know kxstudio, bu=
t IMHO it's unlikely that Pd would kick out jack.

Here Ubuntu Lynx AudioPro customized, pd-ext 0.42.5.M=A0

I use kxstudio which allows all audio to be routed to jack by default.

However, when starting pd-extended 0.42.5 jack is killed and this makes lif=
e
rough.

Do I need to recompile pd manually in order to make it play nice?

Thanks for any input.

-Aaron
-------------- next part --------------
An HTML attachment was scrubbed...=
-- Marco DonnarummaIndepende=
nt New Media and Sonic Arts Practitioner, Performer, TeacherACE, Sound =
Design MSc by Research (ongoing)

The University of Edinburgh, UK~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Portfol=
io:=A0http://marc=
odonnarumma.com
Research:=A0http://res.marcodonnarumma.com=A0|=A0http://www.thesaddj.com=A0|=
=A0http://www.flxer.net=

Director:=A0http://www.liveperformersmeeting.net

--001517447ad0a83e9804ab077d46--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAU] starting pd-extended 0.42.5, Marco Donnarumma, (Sun Aug 21, 12:32 pm)
Re: [LAU] starting pd-extended 0.42.5, Aaron L., (Sun Aug 21, 5:42 pm)
Re: [LAU] starting pd-extended 0.42.5, Aaron L., (Sun Aug 21, 5:45 pm)