Re: [LAU] Does my audio card has a hardware MIDI synthesizer?

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Cedric Roux <sed@...>
Cc: <linux-audio-user@...>
Date: Wednesday, January 20, 2010 - 11:57 am

--0016e6d566525e279f047d974b32
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

You generally won't need one anyways.. You probably just need to load the
kernel module snd-seq
and make sure that it is loaded at startup.

On Wed, Jan 20, 2010 at 9:49 PM, Cedric Roux wrote:

> Hi people from LAU,

-
K]

--0016e6d566525e279f047d974b32
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

You generally won't need one anyways.. You probably just need to load t=
he kernel module snd-seqand make sure that it is loaded at startup.=
On Wed, Jan 20, 2010 at 9:49 PM, Cedric Roux=
<sed@free.fr> wrote:
Hi people from LA=
U,

I have a problem.
Maybe you can help me.
I searched the web, but couldn't find the info.
So the question is in the title.

Here is what I know about the card (the computer
is at work, I don't have full specs).

It's a Dell, Intel CPU, standard stuff I guess.
The audio card is on the PCI bus.
Here is what lspci has to say about that.
----
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audi=
o Controller [8086:293e] (rev 02)
=A0 =A0 =A0 =A0Subsystem: Dell Device [1028:0214]
=A0 =A0 =A0 =A0Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-=
ParErr- Stepping- SERR+ FastB2B- DisINTx-
=A0 =A0 =A0 =A0Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=3Dfast &gt=
;TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
=A0 =A0 =A0 =A0Latency: 0, Cache Line Size: 64 bytes
=A0 =A0 =A0 =A0Interrupt: pin A routed to IRQ 16
=A0 =A0 =A0 =A0Region 0: Memory at fdffc000 (64-bit, non-prefetchable) [si=
ze=3D16K]
=A0 =A0 =A0 =A0Capabilities: [50] Power Management version 2
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0Flags: PMEClk- DSI- D1- D2- AuxCurrent=3D55=
mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0Status: D0 PME-Enable- DSel=3D0 DScale=3D0 =
PME-
=A0 =A0 =A0 =A0Capabilities: [60] Message Signalled Interrupts: Mask- 64bi=
t+ Queue=3D0/0 Enable-
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0Address: 0000000000000000 =A0Data: 0000
=A0 =A0 =A0 =A0Capabilities: [70] Express (v1) Root Complex Integrated End=
point, MSI 00
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0DevCap: MaxPayload 128 bytes, PhantFunc 0, =
Latency L0s <64ns, L1 <1us
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0ExtTag- RBE- FLReset+
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0DevCtl: Report errors: Correctable- Non-Fat=
al- Fatal- Unsupported-
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0RlxdOrd- ExtTag- PhantFunc-=
AuxPwr- NoSnoop+
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0MaxPayload 128 bytes, MaxRe=
adReq 128 bytes
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0DevSta: CorrErr- UncorrErr- FatalErr- Unsup=
pReq- AuxPwr+ TransPend-
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0LnkCap: Port #0, Speed unknown, Width x0, A=
SPM unknown, Latency L0 <64ns, L1 <1us
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0ClockPM- Suprise- LLActRep-=
BwNot-
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0LnkCtl: ASPM Disabled; Disabled- Retrain- C=
ommClk-
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0ExtSynch- ClockPM- AutWidDi=
s- BWInt- AutBWInt-
=A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0LnkSta: Speed unknown, Width x0, TrErr- Tra=
in- SlotClk- DLActive- BWMgmt- ABWMgmt-
=A0 =A0 =A0 =A0Capabilities: [100] Virtual Channel <?>
=A0 =A0 =A0 =A0Capabilities: [130] Root Complex Link <?>
=A0 =A0 =A0 =A0Kernel driver in use: HDA Intel
=A0 =A0 =A0 =A0Kernel modules: snd-hda-intel
----
I bet the important stuff is the 1028:0214 PCI number, right?

Alsa shows no MIDI device whatsoever (there is a 'Midi Through'
stuff, but that does not count, right?).

So I'm stuck here.
Any help is welcome.
Yeah, timidity works fine, that's not the point. I want
to use the hardware synthesizer (if there is one).

Thanks,
C=E9dric.
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@l=
ists.linuxaudio.org

http://lists.linuxaudio.org/listinfo/linux-audio-user

--0016e6d566525e279f047d974b32--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAU] Does my audio card has a hardware MIDI synthesizer?, Danni Coy, (Wed Jan 20, 11:57 am)