[LAU] windows (wine) apps can no longer see alsa midi ports

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Friday, August 22, 2008 - 5:47 pm

While I was asleep last night wine applications lost the ability to
recognise alsa midi ports (external controller, midi-through etc). In
other words I was able to work with midi last night, but something has
changed. In both Reaper and in Tracktion 3 Demo the box in the
preferences where all the devices were listed last night is now empty.

I thought it might have been a wine upgrade from the official ubuntu
hardy version to the one in the winehq repository (1.1.2), but rolling
it back made no difference. However at some point while I was trying to
get wineasio-x working I tried changing winecfg to disable alsa. When I
first noticed that midi wasn't working winealsa was still disabled, but
after I re-enabled it it still refused to work. In other words I had
done something that could reasonably be expected to cause wine midi to
stop working, but it didn't start working again once I had put this right.

Does anyone have any idea what is going on here?

Many thanks :)
Robert
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/mailman/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] windows (wine) apps can no longer see alsa midi ports, Robert Persson, (Fri Aug 22, 5:47 pm)