[LAU] latency issues (practical aid needed on a practical example)

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: linux-audio-user <linux-audio-user@...>
Date: Tuesday, June 10, 2008 - 7:39 pm

Hi everyone!
I just compiled a sound generator, which can be controlled vai MIDI, it uses
simpe raw-midi and jack as output, via bio2jack.
Now I have horrible latency 0.2-0.5sec (rough estimate). Where should I
start looking in my setupt. I know others had the software running without
problems.
Sorry for being so abstract, but I'm not allowed to mention the software.
:-( But I could post parts of the source if necessary.
My setup is:
Debian Lenny with custom built kernel 2.6.24-rt1
JACK subversion 0.109.0
jack-commandline:
jackd --timeout 4500 -R -d alsa -d hw:1 -r 48000 -p 128 -H -M -z shaped
ALSA version 1.0.15
Any idea where to optimise?
Kindest regards
Julien

--------
Music was my first love and it will be my last (John Miles)

======== FIND MY WEB-PROJECT AT: ========
http://ltsb.sourceforge.net
the Linux TextBased Studio guide
======= AND MY PERSONAL PAGES AT: =======
http://www.juliencoder.de
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/mailman/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] latency issues (practical aid needed on a practical ex..., Julien Claassen, (Tue Jun 10, 7:39 pm)