[LAU] Compiling Patchage...dependencies - Raul and FlowCanvas

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: LAU <linux-audio-user@...>
Date: Monday, May 19, 2008 - 2:33 am

---------- Forwarded message ----------
From: Justin Smith
Date: Sun, May 18, 2008 at 7:31 PM
Subject: Re: [LAU] Compiling Patchage...dependencies - Raul and FlowCanvas
To: Roger Wakeman

On Sun, May 18, 2008 at 7:20 PM, Roger Wakeman wrote:

Did you make and install the new jack by hand or from a package?

If from a package, you will of course need the matching -dev package.
If by hand, you will need to make sure that the location of the new
jack headers is before your old ones in the include path, and that the
version of the new jack libraries is before the old ones in your
ld.so.conf (also make sure to run ldconfig after installing the libs
if the install target did not do that). I assume you know that getting
the newer jack lib means getting new versions of many of the programs
that use jack (otherwise you will discover many an inexplicable bug in
the applications compiled with an out of date jack.h, or apps that are
smart enough to check for a jack version refusing to run and
complaining that they cannot connect to this jack version). Out of
synch versions of jack is not as bad as out of synch libc versions,
but it can be tricky nonetheless.

Updatedb manages the database that man uses to find man pages.
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@lists.linuxaudio.org
http://lists.linuxaudio.org/mailman/listinfo/linux-audio-user

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Compiling Patchage...dependencies - Raul and FlowCanvas, Justin Smith, (Mon May 19, 2:33 am)