Re: [LAU] : jack CPU % is going crazy !

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Pieter Palmers <pieterp@...>
Cc: A list for linux audio users <linux-audio-user@...>
Date: Monday, April 7, 2008 - 2:41 pm

------=_Part_16311_12941348.1207579290729
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

2008/4/7, Pieter Palmers :

but I

h=E9h=E9 :D

Is there a problem in my kernel config ?

n

well, on the same laptop I got a 32bits openSuse system and a gentoo 64bits
in dual boot.
I have tested on OpenSuse, with both Kde3.5 and Fvwm, just using qjackctl
0.3.2 with jackd 0.109 and it works perfectly.
Now on my gentoo 64 bits I tryed on both Kde4.0 and Fvwm-crystal, just usin=
g
qjackctl 0.3.2 and jackdmp0.70. I also tryed with qjackctl 0.2.23 (in case
it was due to QT4 library) and jackdmp-svn and jackd 0.109 : in all the cas=
e
I got the cpu load problem.

Do you think this is a firewire problem ? perhaps I forgot an important
option when I compiled my kernel (2.6.24-rt1)
I think I will try with another kernel. Will see if there is new kernel
available. otherwise I will try with an older (2.6.22 ...)

Thank you for your answer.

ps : pieter if you haven't tested freebob in 64 bits, perhaps you could giv=
e
me some guidelines, to test it and make a report for you ?

cheers,

Mysth-R

--=20
*
***************************************************************************=
************
* {^_^} Mysth-R {^_^}
* <=3D Aide Auditive =3D>
*
* http://myspace.com/mysthr
* http://myspace.com/aideauditive
* http://mysthr.free.fr/Joomla =3D> Site d=E9di=E9 =E0 l'audio sous
Fedora/PlanetCCRMA.
*
***************************************************************************=
************

------=_Part_16311_12941348.1207579290729
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

2008/4/7, Pieter Palmers <pieterp@joow.be>:
Mysth-R wrote:

2008/4/7, Pieter Palmers <pieterp@joo=
w.be
<mailto:pieterp@joow.be&=
gt;>:

   Mysth-R wrote:

       I forgot to precise that my sound card is a Pre=
sonus Firebox and
       run with Freebob.
       I got the idea to test with my U-control Uca202=
(Behringer) Usb
       sound-card, and there is no problems. The cpu p=
ercent is quite
       stable around 2,1%.
       It is a bit strange because I got the rtirq scr=
ipt congiured for
       my firewire card. So it should not work better =
than my firewire ...

       I am a bit lost !!  :O[

   Is the 'real' cpu time (e.g. from top) also that high=
? It could be
   that there is a bug in the time reporting of the freebob back=
end,
   resulting in a bad calculation of the cpu time.

   Greets,

   Pieter

Hi,
It is very strange. I can't see a real correlation between cpu load dis=
played by htop and the DSP load displayed by qjackctl.
In htop the cpu is quite unstable too, but it doesn'tt change at the sa=
me time as the dsp load in qjackctl. Perhaps it is due to a latency. but I =
can't say if is linked.
I have made some more test :

1- runing qjackctl with freebob backend : both dsp load (qjackctl) and cpu =
load (htop) are unstable but not really linked.
2- runing qjackctl with alsa backend : dsp load is quite stable but cpu loa=
d is unstable.
3- running jackdmp in a console with Freebob then alsa : cpu load is unstab=
le.
4- when jackdmp or qjackctl are killed : cpu load is normal around 2% and s=
table.

So :
Is it normal that the cpu load displayed in htop is unstable ?
If it is, then as you said pieter, could it be a bug with freebob ??? I nev=
er saw this before, on the same laptop but with 32bits OS.

FreeBoB is guaranteed 110% bug-free.h=E9h=E9 :D <=
br>

Is there a problem in my kernel config ?
Is there a something wrong with jack or freebob with the 64bits arch ?

It could very well be a 64bit issue somewhere. I haven't tested freebob=
on 64bit yet.

Well, if someone as some idea for me to make more tests ... I would be happ=
y ;)

It might be interesting if you could figure out exactly what the difference=
s are between your setups. Mainly software versions etc...well, on the same laptop I got a 32bits openSuse system and a gentoo 6=
4bits in dual boot.
I have tested on OpenSuse, with both Kde3.5 and Fvwm, just using qjackctl 0=
.3.2 with jackd 0.109 and it works perfectly.Now on my gentoo 64 bits I=
tryed on both Kde4.0 and Fvwm-crystal, just using qjackctl 0.3.2 and jackd=
mp0.70. I also tryed with qjackctl 0.2.23 (in case it was due to QT4 librar=
y) and jackdmp-svn and jackd 0.109 : in all the case I got the cpu load pro=
blem.
Do you think this is a firewire problem ? perhaps I forgot an important=
option when I compiled my kernel (2.6.24-rt1)I think I will try with a=
nother kernel. Will see if there is new kernel available. otherwise I will =
try with an older (2.6.22 ...)
Thank you for your answer.ps : pieter if you haven't tested=
freebob in 64 bits, perhaps you could give me some guidelines, to test it =
and make a report for you ?cheers,Mysth-R
-- * **************************************************************=
**************************  {^_^} Mysth-R {^_^}* &nb=
sp;<=3D Aide Auditive =3D>** http://myspace.com/mysthr
* http://myspace.com/aideauditi=
ve
* http://mysthr.free.fr/=
Joomla
  =3D> Site d=E9di=E9 =E0 l'audio sous Fedora/Pl=
anetCCRMA.* ***********************************************************=
****************************

------=_Part_16311_12941348.1207579290729--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] : jack CPU % is going crazy !, Mysth-R, (Sat Apr 5, 5:27 pm)
Re: [LAU] : jack CPU % is going crazy !, Russell Hanaghan, (Sat Apr 5, 8:59 pm)
Re: [LAU] : jack CPU % is going crazy !, Mysth-R, (Sun Apr 6, 1:12 pm)
Re: [LAU] : jack CPU % is going crazy !, Mysth-R, (Sun Apr 6, 1:24 pm)
Re: [LAU] : jack CPU % is going crazy !, Pieter Palmers, (Mon Apr 7, 7:00 am)
Re: [LAU] : jack CPU % is going crazy !, Mysth-R, (Mon Apr 7, 9:43 am)
Re: [LAU] : jack CPU % is going crazy !, Pieter Palmers, (Mon Apr 7, 11:14 am)
Re: [LAU] : jack CPU % is going crazy !, Mysth-R, (Mon Apr 7, 2:41 pm)
Re: [LAU] : jack CPU % is going crazy !, Pieter Palmers, (Mon Apr 7, 3:06 pm)
Re: [LAU] : jack CPU % is going crazy !, Mysth-R, (Tue Apr 8, 12:27 pm)