Re: [LAU] Re: problems with Bristol on x86_64 SOLVED

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Wednesday, April 18, 2007 - 8:29 am

Hi All,

>to hack a bit with the build process to put everything in the standard

There is an enhancement request open to put the source code under the GNU
tools including install option. Its not top of my list but it is there.

>Also, I haven't figured out how to assign MIDI controllers to the graphics

The engine and GUI are separate elements. You need to aconnect the engine,
bristol, to a keyboard to be able play it. You also need to connect the GUI,
brighton, to a MIDI controller to be able to drive the GUI. This is also
with aconnect and both bristol and brighton should be visible. Then, place
the mouse over the GUI device you want to control and press the middle mouse
button, then joggle the MIDI control you want to drive it from.

>Even MIDI volume wasn't working on me with the Hammond.

There are a few things here. MIDI volume is a GM2 controller however these
go through the GUI, not through the engine, so it would still need to be
connected up to the GUI for them to possibly work. If you are actually after
a swell pedal I will check the code. The engine does have access to all the
MIDI controllers but only responds, per default, to few of them (pitchbend,
modwheel, and some pressure tracking). It would make sense for some of the
synths to respond to typical input devices such as the pedal in the case of
the b3.

Regards,

Nick.

_________________________________________________________________
FREE pop-up blocking with the new MSN Toolbar - get it now!
http://toolbar.msn.click-url.com/go/onm00200415ave/direct/01/

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAU] Bristol on FC6 x86_64 ?, lanas, (Sun Apr 15, 3:00 pm)
Re: [LAU] Bristol on FC6 x86_64 ?, Mike Taht, (Sun Apr 15, 3:15 pm)
Re: [LAU] Bristol on FC6 x86_64 ?, Mike Taht, (Sun Apr 15, 3:47 pm)
Re: [LAU] Bristol on FC6 x86_64 ?, Mike Taht, (Sun Apr 15, 5:47 pm)
Re: [LAU] Bristol on FC6 x86_64 ?, lanas, (Fri Apr 20, 6:08 pm)
Re: [LAU] Bristol on FC6 x86_64 ?, Fernando Lopez-Lezcano, (Fri Apr 20, 7:57 pm)
[LAU] Re: problems with Bristol on x86_64 SOLVED, Dave Phillips, (Wed Apr 18, 12:28 am)
Re: [LAU] Re: problems with Bristol on x86_64 SOLVED, Larry Troxler, (Wed Apr 18, 3:01 am)
Re: [LAU] Re: problems with Bristol on x86_64 SOLVED, Nick Copeland, (Wed Apr 18, 8:29 am)
Re: [LAU] Re: problems with Bristol on x86_64 SOLVED, Larry Troxler, (Wed Apr 18, 12:15 pm)
Re: [LAU] Re: problems with Bristol on x86_64 SOLVED, Nick Copeland, (Wed Apr 18, 2:46 pm)
Re: [LAU] Re: problems with Bristol on x86_64 SOLVED, Larry Troxler, (Thu Apr 19, 3:16 am)
Re: [LAU] Re: problems with Bristol on x86_64 SOLVED, Ken Restivo, (Wed Apr 18, 2:52 am)
Re: [LAU] Re: problems with Bristol on x86_64 SOLVED, Dave Phillips, (Wed Apr 18, 12:46 pm)