[linux-audio-user] Problems with MIDIsport 2x2

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-user@...>
Date: Monday, November 28, 2005 - 3:28 am

Dear all,
Having just updated my Gentoo kernel from 2.6.11 to 2.6.13
(trying to get my Novation Speedio to work - that's still
WIP), I can't get my MIDIsport 2x2 to work any more. Under
2.6.11, it worked easily - I just had to fetch
midisport_firmware-0.5.tar.bz2 from Sourceforge, and follow
the instructions in the readme file there, which showed me
how to set up the firmware loader. But I can't get this to
work any longer. I can manually upload the firmware to the
MIDIsport using this command:

fxload -D /proc/bus/usb/XXX/YYY -I MidiSport2x2.ihx

The MIDIsport then flashes its lights and changes its ID and
bus address ("renumerates", in the wonderful jargon), but
doesn't pick up its driver - here's the relevant section
from /proc/bus/usb/devices:

T: Bus=03 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 14 Spd=12
MxCh= 0
D: Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0763 ProdID=1002 Rev= 1.21
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 5 Cls=ff(vend.) Sub=00 Prot=00
Driver=(none)
E: Ad=81(I) Atr=03(Int.) MxPS= 32 Ivl=1ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 32 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 32 Ivl=0ms
E: Ad=84(I) Atr=02(Bulk) MxPS= 32 Ivl=0ms
E: Ad=04(O) Atr=02(Bulk) MxPS= 32 Ivl=0ms

I have put an entry in /etc/hotplug/usb.usermap, pointing to
the script (midisport_fw) that's supposed to load the
firmware, but no messages appear in the log, suggesting
that the script is not getting run.

What's going wrong? Why is this not working now, when it
was childsplay before?

Any help appreciated,

Peter C

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[linux-audio-user] Problems with MIDIsport 2x2, Peter Clarke, (Mon Nov 28, 3:28 am)
Re: [linux-audio-user] Problems with MIDIsport 2x2, Hans Fugal, (Tue Dec 6, 2:12 pm)
Re: [linux-audio-user] Problems with MIDIsport 2x2, Markus Herhoffer, (Mon Nov 28, 5:11 pm)
Re: [linux-audio-user] Problems with MIDIsport 2x2, Clemens Ladisch, (Mon Nov 28, 3:02 pm)