Re: [LAD] Build error in Guitarix

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Gianfranco Ceccolini <gianfranco@...>
Cc: <linux-audio-dev@...>
Date: Monday, September 30, 2013 - 2:10 pm

Am 30.09.2013 15:26, schrieb Gianfranco Ceccolini:

Hi Gianfranco

mmm, we try a testbuild during configure to find out if the gcc -O3
-ftree-loop-linear flag works proper, if the build/run fail we assume
that cloog isn't installed. I didn't know, but I see on arch there is a
other package cloog:
https://www.archlinux.org/packages/core/x86_64/cloog/
maybe this one works?

However, you can use as well the -cxxflags option when configure, the
flags I would recommended are
./waf configure --prefix=/usr --includeresampler --convolver-ffmpeg
--no-ladspa --cxxflags='-march=native -mfpmath=sse -msse2
-fomit-frame-pointer -ffinite-math-only -fno-math-errno
-fno-signed-zeros -fstrength-reduce -pipe'

> Is there something else to be done in order to get the optimization

I'm glad you like what we do, feel free to use/include what ever you
like from guitarix to the MOD, as I'm enjoy the MOD as well very much. :-D

_______________________________________________
Linux-audio-dev mailing list
Linux-audio-dev@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-dev

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAD] Build error in Guitarix, Gianfranco Ceccolini, (Mon Sep 30, 1:27 pm)
Re: [LAD] Build error in Guitarix, hermann meyer, (Mon Sep 30, 2:10 pm)
Re: [LAD] Build error in Guitarix, Gianfranco Ceccolini, (Tue Oct 1, 1:00 am)
Re: [LAD] Build error in Guitarix, Gianfranco Ceccolini, (Tue Oct 1, 1:10 am)