[LAD] zita-ajbridge and aloop

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <Linux-audio-dev@...>
Date: Thursday, July 11, 2013 - 1:59 pm

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

hi all,

(apologies if this is the wrong mailing list, but i'm currently only
subscribed to LAD and not LAU. anyhow:)

i'm having serious troubles using zita-ajbridge with alsa loopback
devices.

my basic requirement is, to allow *any* ALSA-only application to be
"jackified".

i'm on debian, and my current tests are done on i386 resp. x86_64, but
my target platform is armel (wandboard solo, powered by a single-core
ARM cortex-A9)

the basic problem i'm facing is, that i don't get much output.
occasionally i do get output (e.g. with mplayer)

so here's what i did:

# modprobe snd-aloop (with all the default parameters)

which gives me:

$ cat /proc/asound/cards
0 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xf0244000 irq 43
1 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xf0240000 irq 16
2 [Loopback ]: Loopback - Loopback
Loopback 1

$ zita-a2j -v -d hw:Loopback,0 -L
playback : not enabled
capture :
nchan : 2
fsamp : 48000
fsize : 256
nfrag : 2
format : S16_LE
Starting synchronisation.
0.460 0.999864
[...]

on another terminal i do:
$ mplayer -ao alsa:device=hw=Loopback.1 STE48.wav

and after connecting zita-a2j to my system's output, i can hear sound.
cool!

ok, so i stop mplayer, and start some other application e.g. Pd (what
else). hooking it up to the loopback device, i start my testpatch:
silence :-(

ok, so mabye Pd is broken, i try some zita app, e.g. zita_delay (from
libzita-alsa-pcmi)

$ alsa_delay hw:Loopback,0 hw:Loopback,0 48000 1024 2
playback :
nchan : 32
fsamp : 48000
fsize : 1024
nfrag : 2
format : FLOAT_LE
capture :
nchan : 32
fsamp : 48000
fsize : 1024
nfrag : 2
format : FLOAT_LE
synced
Signal below threshold...
Signal below threshold...
[...]

not very surprisingly, it doesn't detect any input signal (zita-j2a is
not running), but i also don't hear any output signal.
hmm.

stopping jack (which quits zita-a2j), i try a alsa_delay on my soundcard:
$ alsa_delay hw:SB,0 hw:SB,0 48000 1024 2
playback :
nchan : 2
fsamp : 48000
fsize : 1024
nfrag : 2
format : S32_LE
capture :
nchan : 2
fsamp : 48000
fsize : 1024
nfrag : 2
format : S32_LE
synced
2176.341 frames 45.340 ms ??
2176.405 frames 45.342 ms ??

and i hear nice sine-tones.

checking the output of alsa_delay vs that of zita-a2j, i notice that
one uses latter S32_LE whereas the former uses FLOAT_LE.
since i cannot change the format of alsa_delay without recompilation,
i try to match the two formats with zita-a2j, by running:

$ zita-a2j -v -d hw:Loopback,0 -p 1024
$ zita-a2j -v -d hw:Loopback,0 -p 1024
playback : not enabled
capture :
nchan : 32
fsamp : 48000
fsize : 1024
nfrag : 2
format : FLOAT_LE
Starting synchronisation.
3.716 0.999042
2.713 0.998499
[...]

which gives me pretty much the same config as is used with alsa_delay.

re-starting `alsa_delay`: still no sound.

just in case: starting zita-j2a as well:
$ zita-j2a -v -d hw:Loopback,0 -p 1024
playback :
nchan : 32
fsamp : 48000
fsize : 1024
nfrag : 2
format : FLOAT_LE
capture : not enabled
Starting synchronisation.
-2.919 1.000933
-1.457 1.001286
[...]

and making sure that zita-*2* are jack-connected to system, but still
no luck.

hmm, what is going on here?

currently the *only* application that i can convince to use
zita-ajbridge seems to be mplayer, and only in S16_LE mode.

what are the requirements for an application to use zita-ajbridge?
shouldn't other zita applications (like alsa_delay) automagically
fullfill these requirements through libzita-alsa-pcmi?
do my application either have to support FLOAT_LE or be stuck with
S16_LE/2channels forever?

is there a tutorial out there on how to use zita-ajbridge with snd-aloop?

masdr
IOhannes
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Icedove - http://www.enigmail.net/

iEYEARECAAYFAlHeuicACgkQkX2Xpv6ydvRT+ACcC0ZW07gHvW6ub3HXhWG8sXR8
TYcAn1SALKnlTeFYJmtPz8gkvpX+aLNB
=BuNd
-----END PGP SIGNATURE-----
_______________________________________________
Linux-audio-dev mailing list
Linux-audio-dev@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-dev

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAD] zita-ajbridge and aloop, IOhannes m zmoelnig, (Thu Jul 11, 1:59 pm)
Re: [LAD] zita-ajbridge and aloop, Dominique Michel, (Thu Jul 11, 6:49 pm)
Re: [LAD] zita-ajbridge and aloop, Joel Roth, (Fri Jul 12, 12:52 am)
Re: [LAD] zita-ajbridge and aloop, Dominique Michel, (Fri Jul 12, 9:17 pm)
Re: [LAD] zita-ajbridge and aloop, Fons Adriaensen, (Thu Jul 11, 3:58 pm)
Re: [LAD] zita-ajbridge and aloop, IOhannes m zmoelnig, (Mon Jul 15, 11:46 am)
Re: [LAD] zita-ajbridge and aloop, IOhannes m zmoelnig, (Wed Jul 17, 3:21 pm)
Re: [LAD] zita-ajbridge and aloop, Fons Adriaensen, (Wed Jul 17, 8:09 pm)
Re: [LAD] zita-ajbridge and aloop, IOhannes m zmoelnig, (Wed Jul 17, 3:29 pm)