Re: [LAD] Announcing PHASEX-0.14.96

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
From: SxDx <sed@...>
To: Florian Paul Schmidt <mista.tapas@...>
Cc: <linux-audio-dev@...>
Date: Sunday, December 30, 2012 - 4:31 pm

> From: "Florian Paul Schmidt"

same error here. auto[conf|make] is not my thing,
so I don't know how to fix it. (People, put the
-l things AFTER the *.o in your gcc lines. The linker
will skip unreferenced symbols in a shared lib and we
end up with zillions of "undefined reference".) (For
auto/this/that I don't know how you have to specify
that. Maybe it's not your fault by the way. I am with
ubuntu here. Ubuntu is weird.)

However, if you add everything from "-lasound" to "-lX11" that appears
in the line 5 of your paste and put it at the end
(just add it, no matter if the things appear twice,
at least here for me), then it will link. (Do it in src/
of course).

Then back to ../ and "make" "make install" and the thing
will install itself.

That worked here for me.
_______________________________________________
Linux-audio-dev mailing list
Linux-audio-dev@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-dev

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAD] Announcing PHASEX-0.14.96, Florian Paul Schmidt, (Sun Dec 30, 10:39 am)
Re: [LAD] Announcing PHASEX-0.14.96, SxDx, (Sun Dec 30, 4:31 pm)
Re: [LAD] Announcing PHASEX-0.14.96, SxDx, (Sun Dec 30, 4:58 pm)
Re: [LAD] Announcing PHASEX-0.14.96, Florian Paul Schmidt, (Sun Dec 30, 5:12 pm)