Re: [LAD] building the new Guitarix LV2 Amp

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: David Robillard <d@...>
Cc: <linux-audio-dev@...>
Date: Tuesday, December 11, 2012 - 6:29 pm

This is a multi-part message in MIME format.
--------------090707080800040101080702
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

It isn't a problem to do that in a 32bit environment, but however, I
will set the build flag for libgxw/gxwmm to cshlib (build shared libs)
when the lv2 plug is set to build, to avoid such trouble.
As I said in the previous mail, just add --shared-lib to ./waf configure
will solved it for now.

greets
hermann

Am 11.12.2012 17:31, schrieb David Robillard:

--------------090707080800040101080702
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

It isn't a problem to do that in a 32bit environment, but however, I
will set the build flag for libgxw/gxwmm to cshlib (build shared
libs) when the lv2 plug is set to build, to avoid such trouble.
As I said in the previous mail, just add --shared-lib to ./waf
configure will solved it for now.

greets
hermann

Am 11.12.2012 17:31, schrieb David Robillard:
Looks like you are building against a static library.
Since you are building a shared module, pedantically you can't do
this, in practice you at least need to be sure all code is built
with -fPIC. Presumably the static library mentioned is not, which
is your problem.

I am not familiar with libgxmm or the guitarix LV2 work
specifically, sorry, no concrete suggestions.

Gianfranco Ceccolini <franconassis@gmail.com> wrote:

Hello all

I've tried building the new LV2 Amp from guitarix and the
following error is ocurring

/usr/bin/ld:
default/libgxwmm/gxwmm/libgxwmm.a(controlparameter_83.o):
relocation R_X86_64_32 against `_ZTTN3Gxw16ControlParameterE'
can not be used when making a shared object; recompile with
-fPIC
default/libgxwmm/gxwmm/libgxwmm.a: could not read symbols:
Bad value

I've already installed the last LV2 from SVN.

Using Debian Testing in my box.

Any ideas on waht I'm doing wrong?

Thanks for all

Gian

--
Antes de imprimir pense em sua responsabilidade e compromisso
com o MEIO AMBIENTE!

_______________________________________________
Linux-audio-dev mailing list
Linux-audio-dev@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-dev

--------------090707080800040101080702--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
Re: [LAD] building the new Guitarix LV2 Amp, David Robillard, (Tue Dec 11, 4:38 pm)
Re: [LAD] building the new Guitarix LV2 Amp, Chris Cannam, (Wed Dec 12, 9:34 pm)
Re: [LAD] building the new Guitarix LV2 Amp, David Robillard, (Thu Dec 13, 3:16 am)
Re: [LAD] building the new Guitarix LV2 Amp, hermann meyer, (Thu Dec 13, 6:09 am)
Re: [LAD] building the new Guitarix LV2 Amp, David Robillard, (Thu Dec 13, 6:35 am)
Re: [LAD] building the new Guitarix LV2 Amp, hermann meyer, (Thu Dec 13, 7:16 am)
Re: [LAD] building the new Guitarix LV2 Amp, hermann meyer, (Thu Dec 13, 7:53 am)
Re: [LAD] building the new Guitarix LV2 Amp, Gianfranco Ceccolini, (Thu Dec 13, 5:21 pm)
Re: [LAD] building the new Guitarix LV2 Amp, hermann meyer, (Thu Dec 13, 6:00 pm)
Re: [LAD] building the new Guitarix LV2 Amp, Gianfranco Ceccolini, (Thu Dec 13, 6:08 pm)
Re: [LAD] building the new Guitarix LV2 Amp, David Robillard, (Sun Dec 16, 6:12 am)
Re: [LAD] building the new Guitarix LV2 Amp, hermann meyer, (Thu Dec 13, 6:38 pm)
Re: [LAD] building the new Guitarix LV2 Amp, hermann meyer, (Wed Dec 12, 11:26 am)
Re: [LAD] building the new Guitarix LV2 Amp, David Robillard, (Wed Dec 12, 7:35 pm)
Re: [LAD] building the new Guitarix LV2 Amp, hermann meyer, (Wed Dec 12, 8:17 pm)
Re: [LAD] building the new Guitarix LV2 Amp, hermann meyer, (Tue Dec 11, 6:29 pm)
Re: [LAD] building the new Guitarix LV2 Amp, David Robillard, (Wed Dec 12, 12:02 am)