[LAD] issue with AD1989A codec and alsamixer

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: <linux-audio-dev@...>
Date: Tuesday, February 1, 2011 - 10:49 am

--001636416c475fef4d049b3647e5
Content-Type: text/plain; charset=ISO-8859-1

Hi all,

I am working on a system which includes a connexant AD1989A HDA codec
connected to a ATOM processor.
I have four microphones connected to the B and C ports of this codec.
If I change one of the 3 capture gains present in the alsamixer (Capture,
Capture 1 or Capture 3), I can't have any more signal on the B and C ports
It seems to be due to the fact that ALSA breaks (for example for the Capture
gain) the link between the ADC selector 0 and ADC_0 widgets of the codec,
what can be easily seen with codecgraph.

Have you ever had this kind of problem?
Do you know how can I resolve it ?

Many thanks for your asnwers and best regards

Vincent

--001636416c475fef4d049b3647e5
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Hi =
all,I am working on a system which includes a connexant AD1989A HDA=
codec connected to a ATOM processor.I have four microphones connected =
to the B and C ports of this codec.

If I change one of the 3 capture gains present in the alsamixer (Capture, C=
apture 1 or Capture 3), I can't have any more signal on the B and C por=
ts

It seems to be due to the fact that ALSA breaks (for example for the Captur=
e gain) the link between the ADC selector 0 and ADC_0 widgets of the codec,=
what can be easily seen with codecgraph.
Have you ever had this kind of problem?

Do you know how can I resolve it ?Many thanks for your asnwers and =
best regardsVincent

--001636416c475fef4d049b3647e5--

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

This is the only confirmed message in this thread.