Re: [LAD] Some mudita24 fixes in SVN now.

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: Linux Audio Developers <linux-audio-dev@...>, James Morris <jwm.art.net@...>, Niels Mayer <nielsmayer@...>
Date: Tuesday, October 18, 2011 - 8:56 pm

Hi list, Niels, James. (Sorry for the repost.)

I have moved the existing code into an attic branch.
This code contains support for very old GTK+ versions, even pre-2.4.
Most users should not use it, but it's there if you need it.
I'll try to put out a legacy release on the project page.

James' supplied patch has been applied to trunk.
The patch fixes some deprecated code and modernizes.
I tried his suggested deprecated GTK+ code removal compiler flags,
but I gather there is more work to be done modernizing the
code, as it will not compile yet with the flags.

I removed all support for very old GTK+ versions in trunk, and have
set the minimum required GTK+ version at 2.20 for now.

READMEs, and some name strings, have been updated for mudita24.

So, if James or anyone else would like to help with mudita24,
you are no longer encumbered by the legacy code and are free to do
what you need to move the program forward, for now and the future.

Thanks. Tim.
_______________________________________________
Linux-audio-dev mailing list
Linux-audio-dev@lists.linuxaudio.org
http://lists.linuxaudio.org/listinfo/linux-audio-dev

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[LAD] Some mudita24 fixes in SVN now., Tim E. Real, (Sat Sep 24, 3:19 am)
Re: [LAD] Some mudita24 fixes in SVN now., Niels Mayer, (Wed Sep 28, 8:22 pm)
Re: [LAD] Some mudita24 fixes in SVN now., Tim E. Real, (Tue Oct 18, 8:56 pm)