[linux-audio-dev] maximum ports -problem

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]
To: The Linux Audio Developers' Mailing List <linux-audio-dev@...>
Date: Wednesday, July 13, 2005 - 12:40 pm

Last night I was setting up a session in Ardour. I had three tracks for
keyboard parts that were from imported audio files, so they did not have
any input ports set. I wanted to bring in drum parts from Hydrogen, and
started setting up tracks to correspond with the tracks I was using in
Hydrogen. I got maybe 3 or 4 tracks set up, with the correct inputs,
and then suddenly Ardour kept telling me that I was out of jack ports
and needed to reset jack. What is this? I had used maybe 4 stereo
ports total. My sound card has 12 in/10 out (but I was wasn't using
them), and Hydrogen presented 32 stereo tracks via Jack, and I was no
where near the limit. I looked at my jack settings via qjackctl and it
was set for 128 ports (assuming this is the same thing).

After I restarted jackd (and not making any changes in qjackctl),
Hydrogen refused to start (it would segfault on startup, but if I
started Hydrogen without jackd it would startup fine), and when I
reopened the same session in Ardour, the entire screen would freeze
(except the mouse).

All of my versions of jack, ardour, etc., are fairly recent, built from
CVS within the past two weeks. I haven't had any chance to look at this
in more detail this morning. Anyone have any suggestions on what I
should look at?

-- Brett
-----------
Programmer by day, Guitarist by Night
http://www.chapelperilous.net
http://www.alhazred.com
http://www.revelmoon.com

Previous message: [thread] [date] [author]
Next message: [thread] [date] [author]

Messages in current thread:
[linux-audio-dev] maximum ports -problem, Brett McCoy, (Wed Jul 13, 12:40 pm)
Re: [linux-audio-dev] maximum ports -problem, Steve Harris, (Wed Jul 13, 1:03 pm)
Re: [linux-audio-dev] maximum ports -problem, Brett McCoy, (Wed Jul 13, 1:10 pm)
Re: [linux-audio-dev] maximum ports -problem, Steve Harris, (Wed Jul 13, 1:21 pm)
Re: [linux-audio-dev] maximum ports -problem, Brett McCoy, (Wed Jul 13, 1:25 pm)
Re: [linux-audio-dev] maximum ports -problem, Steve Harris, (Wed Jul 13, 1:34 pm)
Re: [linux-audio-dev] maximum ports -problem, Paul Davis, (Wed Jul 13, 12:59 pm)
Re: [linux-audio-dev] maximum ports -problem, Brett McCoy, (Wed Jul 13, 1:07 pm)